summaryrefslogtreecommitdiff
path: root/src/Spatial_searching
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-20 16:29:57 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-20 16:29:57 +0000
commit227f58f39835ea33381ddb28f05ce43fcfa058b2 (patch)
tree8bb2ede8681bc9fd380b2c1d2f7bbc4ed3221d86 /src/Spatial_searching
parentc9d1a58d1f1433546c44ebee538957174d520671 (diff)
Fix CMakeLists
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1519 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: a4a5956802d6c22370367180a2ab70aaff3d3cf9
Diffstat (limited to 'src/Spatial_searching')
-rw-r--r--src/Spatial_searching/test/CMakeLists.txt26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/Spatial_searching/test/CMakeLists.txt b/src/Spatial_searching/test/CMakeLists.txt
index 41059286..571c730a 100644
--- a/src/Spatial_searching/test/CMakeLists.txt
+++ b/src/Spatial_searching/test/CMakeLists.txt
@@ -11,18 +11,24 @@ if (GPROF_PATH)
endif()
if(CGAL_FOUND)
- find_package(Eigen3 3.1.0)
- if (EIGEN3_FOUND)
- message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
- include( ${EIGEN3_USE_FILE} )
- include_directories (BEFORE "../../include")
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ message(STATUS "CGAL version: ${CGAL_VERSION}.")
- add_executable( Spatial_searching_test_Spatial_tree_data_structure test_Spatial_tree_data_structure.cpp )
- target_link_libraries(Spatial_searching_test_Spatial_tree_data_structure
- ${CGAL_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ find_package(Eigen3 3.1.0)
+ if (EIGEN3_FOUND)
+ message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
+ include( ${EIGEN3_USE_FILE} )
+ include_directories (BEFORE "../../include")
+
+ add_executable( Spatial_searching_test_Spatial_tree_data_structure test_Spatial_tree_data_structure.cpp )
+ target_link_libraries(Spatial_searching_test_Spatial_tree_data_structure
+ ${CGAL_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ else()
+ message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Spatial_searching tests.")
+ endif()
else()
- message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Spatial_searching tests.")
- endif()
+ message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Subsampling tests. Version 4.8.0 is required.")
+ endif ()
else()
message(WARNING "CGAL not found. It is required for the Spatial_searching tests.")
endif()