summaryrefslogtreecommitdiff
path: root/src/Spatial_searching
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 15:16:13 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 15:16:13 +0000
commit4ef423a7a1140f1fe1a2ce1f1bbee03990638be1 (patch)
tree0fbb1125f21aece94484faf14c3cf99603dc7456 /src/Spatial_searching
parent091796c9be3ac7ddaa96bacc71842a2808da14e4 (diff)
Add spatial searching test
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1327 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: ec003d65063981af9c6fa0dce7324d1fa879d57a
Diffstat (limited to 'src/Spatial_searching')
-rw-r--r--src/Spatial_searching/test/CMakeLists.txt27
-rw-r--r--src/Spatial_searching/test/test_Spatial_tree_data_structure.cpp71
2 files changed, 98 insertions, 0 deletions
diff --git a/src/Spatial_searching/test/CMakeLists.txt b/src/Spatial_searching/test/CMakeLists.txt
new file mode 100644
index 00000000..297b6749
--- /dev/null
+++ b/src/Spatial_searching/test/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 2.6)
+project(Spatial_searching_tests)
+
+if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+endif()
+if (GPROF_PATH)
+ # for gprof to make coverage reports - Jenkins
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
+endif()
+
+if(CGAL_FOUND)
+ find_package(Eigen3 3.1.0)
+ if (EIGEN3_FOUND)
+ message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
+ include( ${EIGEN3_USE_FILE} )
+ include_directories (BEFORE "../../include")
+
+ add_executable( Spatial_searching_test_Spatial_tree_data_structure test_Spatial_tree_data_structure.cpp )
+ target_link_libraries(Spatial_searching_test_Spatial_tree_data_structure ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ else()
+ message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Spatial_searching tests.")
+ endif()
+else()
+ message(WARNING "CGAL not found. It is required for the Spatial_searching tests.")
+endif()
diff --git a/src/Spatial_searching/test/test_Spatial_tree_data_structure.cpp b/src/Spatial_searching/test/test_Spatial_tree_data_structure.cpp
new file mode 100644
index 00000000..e2bb1f87
--- /dev/null
+++ b/src/Spatial_searching/test/test_Spatial_tree_data_structure.cpp
@@ -0,0 +1,71 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Clement Jamin
+ *
+ * Copyright (C) 2016 INRIA Sophia-Antipolis (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#define BOOST_TEST_DYN_LINK
+#define BOOST_TEST_MODULE Spatial_searching - test Spatial_tree_data_structure
+#include <boost/test/unit_test.hpp>
+
+#include <gudhi/Spatial_tree_data_structure.h>
+
+#include <CGAL/Epick_d.h>
+#include <CGAL/Random.h>
+
+#include <array>
+#include <vector>
+#include <iterator>
+
+BOOST_AUTO_TEST_CASE(test_Spatial_tree_data_structure)
+{
+ typedef CGAL::Epick_d<CGAL::Dimension_tag<4> > K;
+ typedef K::FT FT;
+ typedef K::Point_d Point_d;
+ typedef std::vector<Point_d> Point_container;
+
+ typedef Gudhi::spatial_searching::Spatial_tree_data_structure<
+ K, Point_container> Points_ds;
+ typedef typename Points_ds::KNS_range KNS_range;
+ typedef typename Points_ds::KNS_iterator KNS_iterator;
+ typedef typename Points_ds::INS_range INS_range;
+ typedef typename Points_ds::INS_iterator INS_iterator;
+
+ CGAL::Random rd;
+
+ std::vector<Point_d> points;
+ for (int i = 0 ; i < 500 ; ++i)
+ points.push_back(Point_d(std::array<FT,4>({rd.get_double(-1.,1),rd.get_double(-1.,1),rd.get_double(-1.,1),rd.get_double(-1.,1)})));
+
+ Points_ds points_ds(points);
+
+ std::size_t closest_pt_index =
+ points_ds.query_ANN(points[10], 1, false).begin()->first;
+ BOOST_CHECK(closest_pt_index == 10);
+
+ KNS_range kns_range = points_ds.query_ANN(points[20], 10, true);
+
+ KNS_iterator nn_it = kns_range.begin();
+ FT last_dist = -1.;
+ for (auto const& nghb : kns_range)
+ {
+ BOOST_CHECK(nghb.second > last_dist);
+ last_dist = nghb.second;
+ }
+}