summaryrefslogtreecommitdiff
path: root/src/Subsampling/include
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 09:20:44 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 09:20:44 +0000
commit1539aa803375bbb562559ab632d8ce22c6ce940b (patch)
treef92498789d5ff9de93f8d5402987b710eb3edbf1 /src/Subsampling/include
parent80c45e3f6a8a1f823840b3ae9e924362d7e376b7 (diff)
Merged the CMakeLists and added test_choose_by_farthest_point
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1318 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 534a2ac30a2177a780d1f483add2c472d4cedac3
Diffstat (limited to 'src/Subsampling/include')
-rw-r--r--src/Subsampling/include/gudhi/choose_by_farthest_point.h4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Subsampling/include/gudhi/choose_by_farthest_point.h b/src/Subsampling/include/gudhi/choose_by_farthest_point.h
index 61a21f44..9877d5eb 100644
--- a/src/Subsampling/include/gudhi/choose_by_farthest_point.h
+++ b/src/Subsampling/include/gudhi/choose_by_farthest_point.h
@@ -25,6 +25,8 @@
#include <gudhi/Spatial_tree_data_structure.h>
+#include <boost/range.hpp>
+
#include <iterator>
#include <algorithm> // for sort
#include <vector>
@@ -73,7 +75,7 @@ namespace Gudhi {
for (current_number_of_landmarks = 0; current_number_of_landmarks != nbL; current_number_of_landmarks++) {
// curr_max_w at this point is the next landmark
*output_it++ = points[curr_max_w];
- std::cout << curr_max_w << "\n";
+ // std::cout << curr_max_w << "\n";
unsigned i = 0;
for (auto& p : points) {
double curr_dist = sqdist(p, *(std::begin(points) + curr_max_w));