summaryrefslogtreecommitdiff
path: root/src/Subsampling/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-01-20 09:33:33 +0100
committerGard Spreemann <gspr@nonempty.org>2020-01-20 09:33:33 +0100
commit8c751c3929b1727c1e2e2781259ddaa39cfd8df3 (patch)
tree0e680ea9182032cc82a732230217980ada093ee9 /src/Subsampling/test/CMakeLists.txt
parenta11db9cb0c8b35fa393c95d698754bb0c652b1d6 (diff)
parent9acc59fcc1d5001a212e7b9cd6f00a569a625882 (diff)
Merge branch 'dfsg/latest' into debian/sid
Diffstat (limited to 'src/Subsampling/test/CMakeLists.txt')
-rw-r--r--src/Subsampling/test/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/Subsampling/test/CMakeLists.txt b/src/Subsampling/test/CMakeLists.txt
index cf54788e..354021c1 100644
--- a/src/Subsampling/test/CMakeLists.txt
+++ b/src/Subsampling/test/CMakeLists.txt
@@ -1,18 +1,18 @@
project(Subsampling_tests)
if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
- include(GUDHI_test_coverage)
+ include(GUDHI_boost_test)
add_executable( Subsampling_test_pick_n_random_points test_pick_n_random_points.cpp )
- target_link_libraries(Subsampling_test_pick_n_random_points ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ target_link_libraries(Subsampling_test_pick_n_random_points ${CGAL_LIBRARY})
add_executable( Subsampling_test_choose_n_farthest_points test_choose_n_farthest_points.cpp )
- target_link_libraries(Subsampling_test_choose_n_farthest_points ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ target_link_libraries(Subsampling_test_choose_n_farthest_points ${CGAL_LIBRARY})
add_executable(Subsampling_test_sparsify_point_set test_sparsify_point_set.cpp)
- target_link_libraries(Subsampling_test_sparsify_point_set ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ target_link_libraries(Subsampling_test_sparsify_point_set ${CGAL_LIBRARY})
- gudhi_add_coverage_test(Subsampling_test_pick_n_random_points)
- gudhi_add_coverage_test(Subsampling_test_choose_n_farthest_points)
- gudhi_add_coverage_test(Subsampling_test_sparsify_point_set)
+ gudhi_add_boost_test(Subsampling_test_pick_n_random_points)
+ gudhi_add_boost_test(Subsampling_test_choose_n_farthest_points)
+ gudhi_add_boost_test(Subsampling_test_sparsify_point_set)
endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)