summaryrefslogtreecommitdiff
path: root/src/Subsampling/test
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 09:29:59 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 09:29:59 +0000
commit3113edccca8b0ecf1bc3a942abd03f62c7bb0bcb (patch)
treeb299bbd9d202d27ab9984e2b447bc183da2453da /src/Subsampling/test
parent1539aa803375bbb562559ab632d8ce22c6ce940b (diff)
Renamed the test for pick_random_points
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1319 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 2210767dc829ba596409170200ba8fce5d39fdf1
Diffstat (limited to 'src/Subsampling/test')
-rw-r--r--src/Subsampling/test/CMakeLists.txt6
-rw-r--r--src/Subsampling/test/test_pick_random_points.cpp (renamed from src/Subsampling/test/landmarking.cpp)5
2 files changed, 5 insertions, 6 deletions
diff --git a/src/Subsampling/test/CMakeLists.txt b/src/Subsampling/test/CMakeLists.txt
index 3a7fc092..0c591e8b 100644
--- a/src/Subsampling/test/CMakeLists.txt
+++ b/src/Subsampling/test/CMakeLists.txt
@@ -21,8 +21,10 @@ if(CGAL_FOUND)
include( ${EIGEN3_USE_FILE} )
include_directories (BEFORE "../../include")
- add_executable( test_choose_farthest_point test_choose_farthest_point.cpp )
- target_link_libraries(test_choose_farthest_point ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ add_executable( Subsampling_test_pick_random_points test_pick_random_points.cpp )
+
+ add_executable( Subsampling_test_choose_farthest_point test_choose_farthest_point.cpp )
+ target_link_libraries(Subsampling_test_choose_farthest_point ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
add_executable( Subsampling_test_sparsify_point_set test_sparsify_point_set.cpp)
else()
diff --git a/src/Subsampling/test/landmarking.cpp b/src/Subsampling/test/test_pick_random_points.cpp
index a2c85349..13c7dcad 100644
--- a/src/Subsampling/test/landmarking.cpp
+++ b/src/Subsampling/test/test_pick_random_points.cpp
@@ -39,9 +39,6 @@ int main() {
std::cout << "landmark vector contains: ";
for (auto l: landmarks)
std::cout << l << "\n";
-
- landmarks.clear();
- K k;
- Gudhi::choose_by_farthest_point(k, vect, 16, std::back_inserter(landmarks));
+ assert(landmarks_size() == 5);
}