summaryrefslogtreecommitdiff
path: root/src/Subsampling
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-06 15:27:15 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-06 15:27:15 +0100
commit17cf8da254d88fa42cbe9e7bb486147def47c26b (patch)
tree10b60993b4ce0c2a298130bbde8e5ad04e91cdf4 /src/Subsampling
parent12130250d8c25db81a0806dc7444b47c3030315b (diff)
Modify boost tests to be more verbose and errors in colour. I kept coverage tests (was only used by Jenkins) and they still can be activated through an option
Diffstat (limited to 'src/Subsampling')
-rw-r--r--src/Subsampling/test/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/Subsampling/test/CMakeLists.txt b/src/Subsampling/test/CMakeLists.txt
index cf54788e..354021c1 100644
--- a/src/Subsampling/test/CMakeLists.txt
+++ b/src/Subsampling/test/CMakeLists.txt
@@ -1,18 +1,18 @@
project(Subsampling_tests)
if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
- include(GUDHI_test_coverage)
+ include(GUDHI_boost_test)
add_executable( Subsampling_test_pick_n_random_points test_pick_n_random_points.cpp )
- target_link_libraries(Subsampling_test_pick_n_random_points ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ target_link_libraries(Subsampling_test_pick_n_random_points ${CGAL_LIBRARY})
add_executable( Subsampling_test_choose_n_farthest_points test_choose_n_farthest_points.cpp )
- target_link_libraries(Subsampling_test_choose_n_farthest_points ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ target_link_libraries(Subsampling_test_choose_n_farthest_points ${CGAL_LIBRARY})
add_executable(Subsampling_test_sparsify_point_set test_sparsify_point_set.cpp)
- target_link_libraries(Subsampling_test_sparsify_point_set ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ target_link_libraries(Subsampling_test_sparsify_point_set ${CGAL_LIBRARY})
- gudhi_add_coverage_test(Subsampling_test_pick_n_random_points)
- gudhi_add_coverage_test(Subsampling_test_choose_n_farthest_points)
- gudhi_add_coverage_test(Subsampling_test_sparsify_point_set)
+ gudhi_add_boost_test(Subsampling_test_pick_n_random_points)
+ gudhi_add_boost_test(Subsampling_test_choose_n_farthest_points)
+ gudhi_add_boost_test(Subsampling_test_sparsify_point_set)
endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)