summaryrefslogtreecommitdiff
path: root/src/Subsampling
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-14 14:45:22 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-14 14:45:22 +0200
commit64e6c96afa4d1a95b8d6ee74ea910c1cb80ebbd9 (patch)
treeac3bf9907b3a2b34fb92a5ef96f0eff6c933e0b3 /src/Subsampling
parenta1088d88479e6c18c5ade73ffc34bba2bf37bc1d (diff)
Remove gudhi_patches for CGAL and CGAL 4.11.0 is now the minimal CGAL version required. Modification of documentation accordingly
Diffstat (limited to 'src/Subsampling')
-rw-r--r--src/Subsampling/example/CMakeLists.txt4
-rw-r--r--src/Subsampling/test/CMakeLists.txt4
2 files changed, 4 insertions, 4 deletions
diff --git a/src/Subsampling/example/CMakeLists.txt b/src/Subsampling/example/CMakeLists.txt
index f26d107f..28aab103 100644
--- a/src/Subsampling/example/CMakeLists.txt
+++ b/src/Subsampling/example/CMakeLists.txt
@@ -1,6 +1,6 @@
project(Subsampling_examples)
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
add_executable(Subsampling_example_pick_n_random_points example_pick_n_random_points.cpp)
add_executable(Subsampling_example_choose_n_farthest_points example_choose_n_farthest_points.cpp)
add_executable(Subsampling_example_custom_kernel example_custom_kernel.cpp)
@@ -19,4 +19,4 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
install(TARGETS Subsampling_example_custom_kernel DESTINATION bin)
install(TARGETS Subsampling_example_sparsify_point_set DESTINATION bin)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
diff --git a/src/Subsampling/test/CMakeLists.txt b/src/Subsampling/test/CMakeLists.txt
index 924f0925..cf54788e 100644
--- a/src/Subsampling/test/CMakeLists.txt
+++ b/src/Subsampling/test/CMakeLists.txt
@@ -1,6 +1,6 @@
project(Subsampling_tests)
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
include(GUDHI_test_coverage)
add_executable( Subsampling_test_pick_n_random_points test_pick_n_random_points.cpp )
@@ -15,4 +15,4 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
gudhi_add_coverage_test(Subsampling_test_pick_n_random_points)
gudhi_add_coverage_test(Subsampling_test_choose_n_farthest_points)
gudhi_add_coverage_test(Subsampling_test_sparsify_point_set)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)