summaryrefslogtreecommitdiff
path: root/src/Tangential_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-10-11 13:57:03 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-10-11 13:57:03 +0000
commit16aaf4cda5fd97da12a7f1da8b0a5168fac2e289 (patch)
tree31554bf878ca21a6330a4a28116398e400072427 /src/Tangential_complex/example/CMakeLists.txt
parent74bb6a8a2179090ffc5e65bb7e33fdff62ae4a65 (diff)
Problem of merge with tangentialcomplex branch.
Redo in an integration branch git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/tangential_integration@1701 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: fa029e8e90b3e203ea675f02098ec6fe95596f9f
Diffstat (limited to 'src/Tangential_complex/example/CMakeLists.txt')
-rw-r--r--src/Tangential_complex/example/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/Tangential_complex/example/CMakeLists.txt b/src/Tangential_complex/example/CMakeLists.txt
new file mode 100644
index 00000000..7ba043f0
--- /dev/null
+++ b/src/Tangential_complex/example/CMakeLists.txt
@@ -0,0 +1,30 @@
+cmake_minimum_required(VERSION 2.6)
+project(Tangential_complex_examples)
+
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ message(STATUS "CGAL version: ${CGAL_VERSION}.")
+
+ find_package(Eigen3 3.1.0)
+ if (EIGEN3_FOUND)
+ message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
+ include( ${EIGEN3_USE_FILE} )
+ include_directories (BEFORE "../../include")
+
+ add_executable( Tangential_complex_example_basic example_basic.cpp )
+ target_link_libraries(Tangential_complex_example_basic ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
+ add_executable( Tangential_complex_example_with_perturb example_with_perturb.cpp )
+ target_link_libraries(Tangential_complex_example_with_perturb ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Tangential_complex_example_basic ${TBB_LIBRARIES})
+ target_link_libraries(Tangential_complex_example_with_perturb ${TBB_LIBRARIES})
+ endif()
+ else()
+ message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Tangential_complex examples.")
+ endif()
+ else()
+ message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Tangential_complex examples. Version 4.8.0 is required.")
+ endif ()
+else()
+ message(WARNING "CGAL not found. It is required for the Tangential_complex examples.")
+endif()