summaryrefslogtreecommitdiff
path: root/src/Tangential_complex
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-12 10:04:42 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-12 10:04:42 +0000
commit12fa1bbb902bebb2ffc21482a25913ac7c49dc85 (patch)
treef514d4b62cfdb23bdd718572ba7c267da6763868 /src/Tangential_complex
parentee3a59722aa0902c7fbde0f923c558b3b7dbb0b2 (diff)
Fix the bug, remove tan_test from examples and add a unitary test
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/tangential_test@1850 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 852570382d6f5713e534b49e7abf1e96a4a84076
Diffstat (limited to 'src/Tangential_complex')
-rw-r--r--src/Tangential_complex/example/CMakeLists.txt5
-rw-r--r--src/Tangential_complex/example/tan_test.cpp54
-rw-r--r--src/Tangential_complex/include/gudhi/Tangential_complex.h8
-rw-r--r--src/Tangential_complex/test/test_tangential_complex.cpp57
4 files changed, 63 insertions, 61 deletions
diff --git a/src/Tangential_complex/example/CMakeLists.txt b/src/Tangential_complex/example/CMakeLists.txt
index 76ba0a32..32f6eebb 100644
--- a/src/Tangential_complex/example/CMakeLists.txt
+++ b/src/Tangential_complex/example/CMakeLists.txt
@@ -8,12 +8,9 @@ if(CGAL_FOUND)
target_link_libraries(Tangential_complex_example_basic ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
add_executable( Tangential_complex_example_with_perturb example_with_perturb.cpp )
target_link_libraries(Tangential_complex_example_with_perturb ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
- add_executable( tan_test tan_test.cpp )
- target_link_libraries(tan_test ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Tangential_complex_example_basic ${TBB_LIBRARIES})
target_link_libraries(Tangential_complex_example_with_perturb ${TBB_LIBRARIES})
- target_link_libraries(tan_test ${TBB_LIBRARIES})
endif(TBB_FOUND)
add_test(Tangential_complex_example_basic
@@ -22,8 +19,6 @@ if(CGAL_FOUND)
add_test(Tangential_complex_example_with_perturb
${CMAKE_CURRENT_BINARY_DIR}/Tangential_complex_example_with_perturb)
- add_test(tan_test
- ${CMAKE_CURRENT_BINARY_DIR}/tan_test)
endif(EIGEN3_FOUND)
endif(NOT CGAL_VERSION VERSION_LESS 4.8.0)
endif(CGAL_FOUND)
diff --git a/src/Tangential_complex/example/tan_test.cpp b/src/Tangential_complex/example/tan_test.cpp
deleted file mode 100644
index afb9f13c..00000000
--- a/src/Tangential_complex/example/tan_test.cpp
+++ /dev/null
@@ -1,54 +0,0 @@
-#include <gudhi/Tangential_complex.h>
-#include <gudhi/sparsify_point_set.h>
-
-#include <CGAL/Epick_d.h>
-#include <CGAL/Random.h>
-
-#include <array>
-#include <vector>
-
-namespace tc = Gudhi::tangential_complex;
-
-typedef CGAL::Epick_d<CGAL::Dynamic_dimension_tag> Kernel;
-typedef Kernel::FT FT;
-typedef Kernel::Point_d Point;
-typedef Kernel::Vector_d Vector;
-typedef tc::Tangential_complex<
-Kernel, CGAL::Dynamic_dimension_tag,
-CGAL::Parallel_tag> TC;
-
-int main(void) {
- const int INTRINSIC_DIM = 1;
-
- // Generate points on a 2-sphere
- std::vector<Point> points;
- // [[0, 0], [1, 0], [0, 1], [1, 1]]
- std::vector<double> point = {0.0, 0.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- point = {1.0, 0.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- point = {0.0, 1.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- point = {1.0, 1.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
-
- Kernel k;
- for (int i = 0; i < 100; i++) {
-
- // Compute the TC
- TC tc(points, INTRINSIC_DIM, k);
- tc.compute_tangential_complex();
- TC::Num_inconsistencies num_inc = tc.number_of_inconsistent_simplices();
- std::cout << "TC vertices = " << tc.number_of_vertices() << " - simplices = " << num_inc.num_simplices <<
- " - inconsistencies = " << num_inc.num_inconsistent_simplices << std::endl;
-
- tc.fix_inconsistencies_using_perturbation(10.0, 60.0);
- // Export the TC into a Simplex_tree
- Gudhi::Simplex_tree<> stree;
- tc.create_complex(stree);
- std::cout << "ST vertices = " << stree.num_vertices() << " - simplices = " << stree.num_simplices() << std::endl;
-
- }
-
- return 0;
-}
diff --git a/src/Tangential_complex/include/gudhi/Tangential_complex.h b/src/Tangential_complex/include/gudhi/Tangential_complex.h
index e748d3b7..90c164e2 100644
--- a/src/Tangential_complex/include/gudhi/Tangential_complex.h
+++ b/src/Tangential_complex/include/gudhi/Tangential_complex.h
@@ -1303,7 +1303,9 @@ class Tangential_complex {
, bool normalize_basis = true
, Orthogonal_space_basis *p_orth_space_basis = NULL
) {
- unsigned int num_pts_for_pca = static_cast<unsigned int> (std::pow(GUDHI_TC_BASE_VALUE_FOR_PCA, m_intrinsic_dim));
+// unsigned int num_pts_for_pca = static_cast<unsigned int> (std::pow(GUDHI_TC_BASE_VALUE_FOR_PCA, m_intrinsic_dim));
+ unsigned int num_pts_for_pca = (std::min)(static_cast<unsigned int> (std::pow(GUDHI_TC_BASE_VALUE_FOR_PCA, m_intrinsic_dim)),
+ static_cast<unsigned int> (m_points.size()));
// Kernel functors
typename K::Construct_vector_d constr_vec =
@@ -1392,7 +1394,9 @@ class Tangential_complex {
// on it. Note that most points are duplicated.
Tangent_space_basis compute_tangent_space(const Simplex &s, bool normalize_basis = true) {
- unsigned int num_pts_for_pca = static_cast<unsigned int> (std::pow(GUDHI_TC_BASE_VALUE_FOR_PCA, m_intrinsic_dim));
+// unsigned int num_pts_for_pca = static_cast<unsigned int> (std::pow(GUDHI_TC_BASE_VALUE_FOR_PCA, m_intrinsic_dim));
+ unsigned int num_pts_for_pca = (std::min)(static_cast<unsigned int> (std::pow(GUDHI_TC_BASE_VALUE_FOR_PCA, m_intrinsic_dim)),
+ static_cast<unsigned int> (m_points.size()));
// Kernel functors
typename K::Construct_vector_d constr_vec =
diff --git a/src/Tangential_complex/test/test_tangential_complex.cpp b/src/Tangential_complex/test/test_tangential_complex.cpp
index f8b0d2fb..4c3dec3b 100644
--- a/src/Tangential_complex/test/test_tangential_complex.cpp
+++ b/src/Tangential_complex/test/test_tangential_complex.cpp
@@ -68,3 +68,60 @@ BOOST_AUTO_TEST_CASE(test_Spatial_tree_data_structure) {
Gudhi::Simplex_tree<> stree;
tc.create_complex(stree);
}
+
+BOOST_AUTO_TEST_CASE(test_mini_tangential) {
+ typedef CGAL::Epick_d<CGAL::Dynamic_dimension_tag> Kernel;
+ typedef Kernel::FT FT;
+ typedef Kernel::Point_d Point;
+ typedef Kernel::Vector_d Vector;
+ typedef tc::Tangential_complex<Kernel, CGAL::Dynamic_dimension_tag, CGAL::Parallel_tag> TC;
+
+
+ const int INTRINSIC_DIM = 1;
+
+ // Generate points on a 2-sphere
+ std::vector<Point> points;
+ // [[0, 0], [1, 0], [0, 1], [1, 1]]
+ std::vector<double> point = {0.0, 0.0};
+ points.push_back(Point(point.size(), point.begin(), point.end()));
+ point = {1.0, 0.0};
+ points.push_back(Point(point.size(), point.begin(), point.end()));
+ point = {0.0, 1.0};
+ points.push_back(Point(point.size(), point.begin(), point.end()));
+ point = {1.0, 1.0};
+ points.push_back(Point(point.size(), point.begin(), point.end()));
+ std::cout << "points = " << points.size() << std::endl;
+ Kernel k;
+
+ // Compute the TC
+ TC tc(points, INTRINSIC_DIM, k);
+ tc.compute_tangential_complex();
+ TC::Num_inconsistencies num_inc = tc.number_of_inconsistent_simplices();
+ std::cout << "TC vertices = " << tc.number_of_vertices() << " - simplices = " << num_inc.num_simplices <<
+ " - inconsistencies = " << num_inc.num_inconsistent_simplices << std::endl;
+
+ BOOST_CHECK(tc.number_of_vertices() == 4);
+ BOOST_CHECK(num_inc.num_simplices == 4);
+ BOOST_CHECK(num_inc.num_inconsistent_simplices == 2);
+
+ // Export the TC into a Simplex_tree
+ Gudhi::Simplex_tree<> stree;
+ tc.create_complex(stree);
+ std::cout << "ST vertices = " << stree.num_vertices() << " - simplices = " << stree.num_simplices() << std::endl;
+
+ BOOST_CHECK(stree.num_vertices() == 4);
+ BOOST_CHECK(stree.num_simplices() == 12);
+
+ tc.fix_inconsistencies_using_perturbation(0.01, 30.0);
+
+ BOOST_CHECK(tc.number_of_vertices() == 4);
+ BOOST_CHECK(num_inc.num_simplices == 4);
+ BOOST_CHECK(num_inc.num_inconsistent_simplices == 2);
+
+ // Export the TC into a Simplex_tree
+ tc.create_complex(stree);
+ std::cout << "ST vertices = " << stree.num_vertices() << " - simplices = " << stree.num_simplices() << std::endl;
+
+ BOOST_CHECK(stree.num_vertices() == 4);
+ BOOST_CHECK(stree.num_simplices() == 12);
+}