summaryrefslogtreecommitdiff
path: root/src/Tangential_complex
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-15 09:27:42 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-15 09:27:42 +0000
commitc7cd528c7fa9a548dd47586ae258d33168e04a07 (patch)
tree8434d44fc072d82caf2bbfcb785d54cd41866938 /src/Tangential_complex
parent28b7623d0aed90abe58260861c85b20e43227216 (diff)
Remove example.cpp
Remove tangent traces in Tangential_complex.h Modify test_tangential_complex.cpp to make UT work git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/tangential_test@1875 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 1bd09671ca6f30c66cce7b48b382e1a8e4fbd3b5
Diffstat (limited to 'src/Tangential_complex')
-rw-r--r--src/Tangential_complex/example/CMakeLists.txt3
-rw-r--r--src/Tangential_complex/example/example.cpp85
-rw-r--r--src/Tangential_complex/include/gudhi/Tangential_complex.h5
-rw-r--r--src/Tangential_complex/test/test_tangential_complex.cpp13
4 files changed, 8 insertions, 98 deletions
diff --git a/src/Tangential_complex/example/CMakeLists.txt b/src/Tangential_complex/example/CMakeLists.txt
index 291432b0..32f6eebb 100644
--- a/src/Tangential_complex/example/CMakeLists.txt
+++ b/src/Tangential_complex/example/CMakeLists.txt
@@ -8,12 +8,9 @@ if(CGAL_FOUND)
target_link_libraries(Tangential_complex_example_basic ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
add_executable( Tangential_complex_example_with_perturb example_with_perturb.cpp )
target_link_libraries(Tangential_complex_example_with_perturb ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
- add_executable( example example.cpp )
- target_link_libraries(example ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Tangential_complex_example_basic ${TBB_LIBRARIES})
target_link_libraries(Tangential_complex_example_with_perturb ${TBB_LIBRARIES})
- target_link_libraries(example ${TBB_LIBRARIES})
endif(TBB_FOUND)
add_test(Tangential_complex_example_basic
diff --git a/src/Tangential_complex/example/example.cpp b/src/Tangential_complex/example/example.cpp
deleted file mode 100644
index b7eb542b..00000000
--- a/src/Tangential_complex/example/example.cpp
+++ /dev/null
@@ -1,85 +0,0 @@
-#include <gudhi/Tangential_complex.h>
-#include <gudhi/sparsify_point_set.h>
-
-#include <CGAL/Epick_d.h>
-#include <CGAL/Random.h>
-
-#include <array>
-#include <vector>
-
-namespace tc = Gudhi::tangential_complex;
-
-
-int main(void) {
- typedef CGAL::Epick_d<CGAL::Dynamic_dimension_tag> Kernel;
- typedef Kernel::FT FT;
- typedef Kernel::Point_d Point;
- typedef Kernel::Vector_d Vector;
- typedef tc::Tangential_complex<Kernel, CGAL::Dynamic_dimension_tag, CGAL::Parallel_tag> TC;
-
-
- const int INTRINSIC_DIM = 1;
-
- // Generate points on a 2-sphere
- std::vector<Point> points;
- // [[0, 0], [1, 0], [0, 1], [1, 1]]
- std::vector<double> point = {0.0, 0.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- point = {1.1, 0.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- point = {0.2, 1.3};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- point = {1.0, 1.0};
- points.push_back(Point(point.size(), point.begin(), point.end()));
- std::cout << "points = " << points.size() << std::endl;
- Kernel k;
-
- // Compute the TC
- TC tc(points, INTRINSIC_DIM, k);
- tc.compute_tangential_complex();
- TC::Num_inconsistencies num_inc = tc.number_of_inconsistent_simplices();
- std::cout << "TC vertices = " << tc.number_of_vertices() << " - simplices = " << num_inc.num_simplices <<
- " - inc simplices = " << num_inc.num_inconsistent_simplices << " - inc stars = " << num_inc.num_inconsistent_stars << std::endl;
-
- std::cout << "TC point[0] " << tc.get_point(0) << " - point[1] " << tc.get_point(1) <<
- " - point[2] " << tc.get_point(2) << " - point[3] " << tc.get_point(3) << std::endl;
-
- // Export the TC into a Simplex_tree
- Gudhi::Simplex_tree<> stree;
- int max_dim = tc.create_complex(stree);
- stree.set_dimension(max_dim);
- stree.initialize_filtration();
-
- std::cout << "********************************************************************\n";
- std::cout << "* The complex contains " << stree.num_simplices() << " simplices";
- std::cout << " - dimension " << stree.dimension() << " - filtration " << stree.filtration() << "\n";
- std::cout << "* Iterator on Simplices in the filtration, with [filtration value]:\n";
- for (auto f_simplex : stree.filtration_simplex_range()) {
- std::cout << " " << "[" << stree.filtration(f_simplex) << "] ";
- for (auto vertex : stree.simplex_vertex_range(f_simplex)) {
- std::cout << static_cast<int>(vertex) << " ";
- }
- std::cout << std::endl;
- }
-
- tc.fix_inconsistencies_using_perturbation(0.01, 30.0);
-
- // Export the TC into a Simplex_tree
- max_dim = tc.create_complex(stree);
- stree.set_dimension(max_dim);
- stree.initialize_filtration();
-
- std::cout << "********************************************************************\n";
- std::cout << "* The complex contains " << stree.num_simplices() << " simplices";
- std::cout << " - dimension " << stree.dimension() << " - filtration " << stree.filtration() << "\n";
- std::cout << "* Iterator on Simplices in the filtration, with [filtration value]:\n";
- for (auto f_simplex : stree.filtration_simplex_range()) {
- std::cout << " " << "[" << stree.filtration(f_simplex) << "] ";
- for (auto vertex : stree.simplex_vertex_range(f_simplex)) {
- std::cout << static_cast<int>(vertex) << " ";
- }
- std::cout << std::endl;
- }
-
- return 0;
-}
diff --git a/src/Tangential_complex/include/gudhi/Tangential_complex.h b/src/Tangential_complex/include/gudhi/Tangential_complex.h
index 18919362..6c0bbce6 100644
--- a/src/Tangential_complex/include/gudhi/Tangential_complex.h
+++ b/src/Tangential_complex/include/gudhi/Tangential_complex.h
@@ -1366,11 +1366,6 @@ class Tangential_complex {
eig.eigenvectors().col(j).data() + m_ambient_dim));
}
}
- for (auto v : tsb) {
- for (int i = 0; i < 2; ++i)
- std::cerr << coord(v, i) << ", ";
- std::cerr << "\n";
- }
if (p_orth_space_basis) {
p_orth_space_basis->set_origin(i);
diff --git a/src/Tangential_complex/test/test_tangential_complex.cpp b/src/Tangential_complex/test/test_tangential_complex.cpp
index 4c3dec3b..ebe5cdb4 100644
--- a/src/Tangential_complex/test/test_tangential_complex.cpp
+++ b/src/Tangential_complex/test/test_tangential_complex.cpp
@@ -98,11 +98,13 @@ BOOST_AUTO_TEST_CASE(test_mini_tangential) {
tc.compute_tangential_complex();
TC::Num_inconsistencies num_inc = tc.number_of_inconsistent_simplices();
std::cout << "TC vertices = " << tc.number_of_vertices() << " - simplices = " << num_inc.num_simplices <<
- " - inconsistencies = " << num_inc.num_inconsistent_simplices << std::endl;
+ " - inc simplices = " << num_inc.num_inconsistent_simplices <<
+ " - inc stars = " << num_inc.num_inconsistent_stars << std::endl;
BOOST_CHECK(tc.number_of_vertices() == 4);
BOOST_CHECK(num_inc.num_simplices == 4);
- BOOST_CHECK(num_inc.num_inconsistent_simplices == 2);
+ BOOST_CHECK(num_inc.num_inconsistent_simplices == 0);
+ BOOST_CHECK(num_inc.num_inconsistent_stars == 0);
// Export the TC into a Simplex_tree
Gudhi::Simplex_tree<> stree;
@@ -110,18 +112,19 @@ BOOST_AUTO_TEST_CASE(test_mini_tangential) {
std::cout << "ST vertices = " << stree.num_vertices() << " - simplices = " << stree.num_simplices() << std::endl;
BOOST_CHECK(stree.num_vertices() == 4);
- BOOST_CHECK(stree.num_simplices() == 12);
+ BOOST_CHECK(stree.num_simplices() == 6);
tc.fix_inconsistencies_using_perturbation(0.01, 30.0);
BOOST_CHECK(tc.number_of_vertices() == 4);
BOOST_CHECK(num_inc.num_simplices == 4);
- BOOST_CHECK(num_inc.num_inconsistent_simplices == 2);
+ BOOST_CHECK(num_inc.num_inconsistent_simplices == 0);
+ BOOST_CHECK(num_inc.num_inconsistent_stars == 0);
// Export the TC into a Simplex_tree
tc.create_complex(stree);
std::cout << "ST vertices = " << stree.num_vertices() << " - simplices = " << stree.num_simplices() << std::endl;
BOOST_CHECK(stree.num_vertices() == 4);
- BOOST_CHECK(stree.num_simplices() == 12);
+ BOOST_CHECK(stree.num_simplices() == 6);
}