summaryrefslogtreecommitdiff
path: root/src/Toplex_map
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-06 15:27:15 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-06 15:27:15 +0100
commit17cf8da254d88fa42cbe9e7bb486147def47c26b (patch)
tree10b60993b4ce0c2a298130bbde8e5ad04e91cdf4 /src/Toplex_map
parent12130250d8c25db81a0806dc7444b47c3030315b (diff)
Modify boost tests to be more verbose and errors in colour. I kept coverage tests (was only used by Jenkins) and they still can be activated through an option
Diffstat (limited to 'src/Toplex_map')
-rw-r--r--src/Toplex_map/test/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/Toplex_map/test/CMakeLists.txt b/src/Toplex_map/test/CMakeLists.txt
index 59517db5..2997584d 100644
--- a/src/Toplex_map/test/CMakeLists.txt
+++ b/src/Toplex_map/test/CMakeLists.txt
@@ -1,11 +1,9 @@
project(Toplex_map_tests)
-include(GUDHI_test_coverage)
+include(GUDHI_boost_test)
add_executable( Toplex_map_unit_test toplex_map_unit_test.cpp )
-target_link_libraries(Toplex_map_unit_test ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
-gudhi_add_coverage_test(Toplex_map_unit_test)
+gudhi_add_boost_test(Toplex_map_unit_test)
add_executable( Lazy_toplex_map_unit_test lazy_toplex_map_unit_test.cpp )
-target_link_libraries(Lazy_toplex_map_unit_test ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
-gudhi_add_coverage_test(Lazy_toplex_map_unit_test)
+gudhi_add_boost_test(Lazy_toplex_map_unit_test)