summaryrefslogtreecommitdiff
path: root/src/Toplex_map
diff options
context:
space:
mode:
authorfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-03 13:02:44 +0000
committerfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-03 13:02:44 +0000
commit2aa8114f1b8e55ef3433461c72f102868ce55866 (patch)
treed5850f9ac6cf6a95420dd8ce96d2ec1394b8b2fe /src/Toplex_map
parent5207236bc6cfacf1789b3eac99360a272a008678 (diff)
compile on linux
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/toplex_map@3410 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 01b43f553d2095f852bb40d15abe57aa91c8f3ff
Diffstat (limited to 'src/Toplex_map')
-rw-r--r--src/Toplex_map/benchmark/CMakeLists.txt (renamed from src/Toplex_map/benchmarks/CMakeLists.txt)0
-rw-r--r--src/Toplex_map/benchmark/chrono.cpp (renamed from src/Toplex_map/benchmarks/chrono.cpp)2
-rw-r--r--src/Toplex_map/include/gudhi/Filtered_toplex_map.h4
-rw-r--r--src/Toplex_map/include/gudhi/Lazy_Toplex_map.h1
4 files changed, 4 insertions, 3 deletions
diff --git a/src/Toplex_map/benchmarks/CMakeLists.txt b/src/Toplex_map/benchmark/CMakeLists.txt
index 2341fe06..2341fe06 100644
--- a/src/Toplex_map/benchmarks/CMakeLists.txt
+++ b/src/Toplex_map/benchmark/CMakeLists.txt
diff --git a/src/Toplex_map/benchmarks/chrono.cpp b/src/Toplex_map/benchmark/chrono.cpp
index d93d1e1f..10449b48 100644
--- a/src/Toplex_map/benchmarks/chrono.cpp
+++ b/src/Toplex_map/benchmark/chrono.cpp
@@ -3,7 +3,7 @@
#include <chrono>
#include <gudhi/Simplex_tree.h>
-#include <gudhi/Lazy_toplex_map.h>
+#include <gudhi/Lazy_Toplex_map.h>
using namespace Gudhi;
diff --git a/src/Toplex_map/include/gudhi/Filtered_toplex_map.h b/src/Toplex_map/include/gudhi/Filtered_toplex_map.h
index a3653acd..ed65e36f 100644
--- a/src/Toplex_map/include/gudhi/Filtered_toplex_map.h
+++ b/src/Toplex_map/include/gudhi/Filtered_toplex_map.h
@@ -37,7 +37,7 @@ public:
* in the Filtered_toplex_map.
* \ingroup toplex_map */
template <typename Input_vertex_range>
- std::pair<Simplex, bool> insert_simplex_and_subfaces(const Input_vertex_range &vertex_range, Filtration_value f = nan(""));
+ std::pair<Simplex, bool> insert_simplex_and_subfaces(const Input_vertex_range &vertex_range, Filtration_value f = std::numeric_limits<double>::quiet_NaN());
/** Gives the filtration of the input simplex.
* \ingroup toplex_map */
@@ -68,7 +68,7 @@ Filtered_toplex_map::Filtration_value Filtered_toplex_map::filtration(const Inpu
for(auto kv : toplex_maps)
if(kv.second->membership(vertex_range))
return kv.first; //min only because a map is ordered
- return nan("");
+ return std::numeric_limits<double>::quiet_NaN() ;
}
template <typename Input_vertex_range>
diff --git a/src/Toplex_map/include/gudhi/Lazy_Toplex_map.h b/src/Toplex_map/include/gudhi/Lazy_Toplex_map.h
index 481d33a1..50785b5a 100644
--- a/src/Toplex_map/include/gudhi/Lazy_Toplex_map.h
+++ b/src/Toplex_map/include/gudhi/Lazy_Toplex_map.h
@@ -3,6 +3,7 @@
#include <gudhi/Toplex_map.h>
#include <boost/heap/fibonacci_heap.hpp>
+#include <cmath>
namespace Gudhi {