summaryrefslogtreecommitdiff
path: root/src/Witness_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-27 16:23:54 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-27 16:23:54 +0000
commita99d289c4f37766bc262baa980284fa1a9816d42 (patch)
tree0f7c456c7b06072765b25fe2dc7d7f75c36fcec1 /src/Witness_complex/example/CMakeLists.txt
parenteaedaf52122a397f35fb75df93f83ae9ffdceb7c (diff)
Added the file for knn landmarks (no CGAL include yet). New algorithm for landmark selection: now 10 times faster!
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/witness@580 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 9de270bd67ac33fd1079de7692dd8974441db606
Diffstat (limited to 'src/Witness_complex/example/CMakeLists.txt')
-rw-r--r--src/Witness_complex/example/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Witness_complex/example/CMakeLists.txt b/src/Witness_complex/example/CMakeLists.txt
index 14d23551..fa594de7 100644
--- a/src/Witness_complex/example/CMakeLists.txt
+++ b/src/Witness_complex/example/CMakeLists.txt
@@ -14,9 +14,9 @@ project(GUDHIWitnessComplex)
add_executable ( simple_witness_complex simple_witness_complex.cpp )
add_test(simple_witness_complex ${CMAKE_CURRENT_BINARY_DIR}/simple_witness_complex)
- #add_executable( witness_complex_from_file witness_complex_from_file.cpp )
+ add_executable( witness_complex_from_file witness_complex_from_file.cpp )
#target_link_libraries(witness_complex_from_file ${EIGEN3_LIBRARIES} ${CGAL_LIBRARY})
- #add_test( witness_complex_from_bunny &{CMAKE_CURRENT_BINARY_DIR}/witness_complex_from_file ${CMAKE_SOURCE_DIR}/data/points/bunny_5000 100)
+ add_test( witness_complex_from_bunny &{CMAKE_CURRENT_BINARY_DIR}/witness_complex_from_file ${CMAKE_SOURCE_DIR}/data/points/bunny_5000 100)
add_executable( witness_complex_from_off witness_complex_from_off.cpp )
@@ -35,7 +35,7 @@ if(GMP_FOUND AND CGAL_FOUND)
INCLUDE_DIRECTORIES(${EIGEN3_INCLUDE_DIRS})
INCLUDE_DIRECTORIES(${GMP_INCLUDE_DIR})
INCLUDE_DIRECTORIES(${CGAL_INCLUDE_DIRS})
- add_executable (witness_complex_from_file witness_complex_from_file.cpp )
- target_link_libraries(witness_complex_from_file ${GMP_LIBRARIES} ${EIGEN3_LIBRARIES} ${CGAL_LIBRARY})
- add_test(witness_complex_from_file ${CMAKE_CURRENT_BINARY_DIR}/witness_complex_from_file ${CMAKE_SOURCE_DIR}/data/points/bunny_5000 100)
+ add_executable (witness_complex_knn_landmarks witness_complex_knn_landmarks.cpp )
+ target_link_libraries(witness_complex_knn_landmarks ${EIGEN3_LIBRARIES} ${CGAL_LIBRARY})
+ add_test(witness_complex_knn_landmarks ${CMAKE_CURRENT_BINARY_DIR}/witness_complex_knn_landmarks ${CMAKE_SOURCE_DIR}/data/points/bunny_5000 100)
endif()