summaryrefslogtreecommitdiff
path: root/src/cmake
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-02 23:32:33 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-02 23:32:33 +0100
commit518de123bcf19a85accca5660844355da1106511 (patch)
tree1abbb45a5608ee42b63d342c4431c990e2d98e8d /src/cmake
parent5b01dbc9d59e1e3e5e00d247c6cdeec406a398b5 (diff)
Code review : year is also generated
Diffstat (limited to 'src/cmake')
-rw-r--r--src/cmake/modules/GUDHI_user_version_target.cmake1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/cmake/modules/GUDHI_user_version_target.cmake b/src/cmake/modules/GUDHI_user_version_target.cmake
index c179220c..4fa74330 100644
--- a/src/cmake/modules/GUDHI_user_version_target.cmake
+++ b/src/cmake/modules/GUDHI_user_version_target.cmake
@@ -24,6 +24,7 @@ add_custom_command(TARGET user_version PRE_BUILD COMMAND ${CMAKE_COMMAND} -E
copy ${CMAKE_CURRENT_BINARY_DIR}/src/Doxyfile ${GUDHI_USER_VERSION_DIR}/Doxyfile)
# Generate bib files for Doxygen - cf. root CMakeLists.txt for explanation
+string(TIMESTAMP GUDHI_VERSION_YEAR "%Y")
configure_file(${CMAKE_SOURCE_DIR}/biblio/how_to_cite_gudhi.bib.in "${CMAKE_CURRENT_BINARY_DIR}/biblio/how_to_cite_gudhi.bib" @ONLY)
file(COPY "${CMAKE_SOURCE_DIR}/biblio/how_to_cite_cgal.bib" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/biblio/")
file(COPY "${CMAKE_SOURCE_DIR}/biblio/bibliography.bib" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/biblio/")