summaryrefslogtreecommitdiff
path: root/src/common/test
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-07-01 09:26:36 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-07-01 09:26:36 +0000
commit2ef73a660a093b8350edea9474e887cd6792f8e8 (patch)
tree70e3cc2f2dd95a4f33ba3d7ff6b95b33cdf8292a /src/common/test
parenta06a3bcbd85b2ba43194b1c7d1065c4a1fb5ec32 (diff)
Eigen3 find_package factorization
CGAL find package in root CMakeLists.txt for Witness complex git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/eigen3_cmake_factorization@1377 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 32137f7687837c63ecfab3a2d11114b27873a1f2
Diffstat (limited to 'src/common/test')
-rw-r--r--src/common/test/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index 5f9c5dde..0a88cf8e 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -13,11 +13,7 @@ endif()
# need CGAL 4.7
if(CGAL_FOUND)
if (NOT CGAL_VERSION VERSION_LESS 4.7.0)
- find_package(Eigen3 3.1.0)
if (EIGEN3_FOUND)
- message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
- include( ${EIGEN3_USE_FILE} )
-
add_executable ( poffreader_UT points_off_reader_unit_test.cpp )
target_link_libraries(poffreader_UT ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
@@ -30,10 +26,10 @@ if(CGAL_FOUND)
--log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/poffreader_UT.xml --log_level=test_suite --report_level=no)
else()
- message(WARNING "Eigen3 not found. Version 3.1.0 is required for Alpha shapes feature.")
+ message(WARNING "Eigen3 not found. Version 3.1.0 is required for points_off_reader unitary tests.")
endif()
else()
- message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Alpha shapes feature. Version 4.6.0 is required.")
+ message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile points_off_reader unitary tests. Version 4.7.0 is required.")
endif ()
endif()