summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-01-21 17:44:35 +0100
committerGitHub <noreply@github.com>2022-01-21 17:44:35 +0100
commit1b04e0ff006db9ddaadb519659b6031e706d31df (patch)
tree7dc558deb32ef45e8220061f2e84ca665a3387a6 /src/python/CMakeLists.txt
parent3644492164e237af41aa2cebbc23101da53a4277 (diff)
parentd4303ede6ee862141e7fc89811d0d69b0b90a107 (diff)
Merge pull request #548 from Hind-M/gspr/exact-betti-curve
Gspr/exact betti curve
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 1314b444..a507d34c 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -547,6 +547,11 @@ if(PYTHONINTERP_FOUND)
add_gudhi_py_test(test_representations)
endif()
+ # Betti curves
+ if(SKLEARN_FOUND AND SCIPY_FOUND)
+ add_gudhi_py_test(test_betti_curve_representations)
+ endif()
+
# Time Delay
add_gudhi_py_test(test_time_delay)