summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-11-24 11:03:18 +0100
committerHind-M <hind.montassif@gmail.com>2021-11-24 11:03:18 +0100
commit27d66e5a8a101d80a7dd8b1f21e1cdfb7dedd98e (patch)
tree7770b744c72a4e86b5e7f33f7ddcb59593f3dbc5 /src/python/CMakeLists.txt
parent8b6d8660cedcfe9b95d6edf18ae85358c787226a (diff)
Make the new BettiCurve class compatible with the old interface
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 26b8b7d6..2a5b961b 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -535,8 +535,8 @@ if(PYTHONINTERP_FOUND)
add_gudhi_py_test(test_representations)
endif()
- # Betti curves.
- if(SCIPY_FOUND)
+ # Betti curves
+ if(SKLEARN_FOUND AND SCIPY_FOUND)
add_gudhi_py_test(test_betti_curve_representations)
endif()