summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-01-04 17:54:23 +0100
committerGitHub <noreply@github.com>2022-01-04 17:54:23 +0100
commit5eea7c4065873d5542df9a6c18acaf2402cf7822 (patch)
treee1cbb885d7e69a0f8d3ae62a646637847f3fc5a7 /src/python/CMakeLists.txt
parent1572629b30ec630799eb64763b58b54f0884ff25 (diff)
parenta2b5e8afab53835ef442451c6763c103f02ac4f5 (diff)
Merge pull request #556 from Hind-M/python_tests_debug
Fix failing tests in debug mode
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 0603ba71..1314b444 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -250,7 +250,7 @@ if(PYTHONINTERP_FOUND)
if (TBB_FOUND AND WITH_GUDHI_USE_TBB)
add_gudhi_debug_info("TBB version ${TBB_INTERFACE_VERSION} found and used")
set(GUDHI_PYTHON_EXTRA_COMPILE_ARGS "${GUDHI_PYTHON_EXTRA_COMPILE_ARGS}'-DGUDHI_USE_TBB', ")
- if(CMAKE_BUILD_TYPE MATCHES Debug)
+ if((CMAKE_BUILD_TYPE MATCHES Debug) AND TBB_DEBUG_LIBRARY)
add_GUDHI_PYTHON_lib("${TBB_DEBUG_LIBRARY}")
add_GUDHI_PYTHON_lib("${TBB_MALLOC_DEBUG_LIBRARY}")
else()