summaryrefslogtreecommitdiff
path: root/src/python/doc/installation.rst
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-11-22 16:19:36 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-11-22 16:19:36 +0100
commiteefdb67e436ba3b881c06b8248d169209dd7016c (patch)
treef6d65dadbee1fcf9c4010894ed578a53c592c370 /src/python/doc/installation.rst
parent0bceb28453a10d94571ff7adff8ddbe19cae0eba (diff)
Add information about *make python* and *make clean* target. It does not fix, but workaround issues #88 #89 and #90
Diffstat (limited to 'src/python/doc/installation.rst')
-rw-r--r--src/python/doc/installation.rst25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/python/doc/installation.rst b/src/python/doc/installation.rst
index 7699a5bb..54504413 100644
--- a/src/python/doc/installation.rst
+++ b/src/python/doc/installation.rst
@@ -40,6 +40,20 @@ To build the GUDHI Python module, run the following commands in a terminal:
cd python
make
+.. note::
+
+ :code:`make python` (or :code:`make` in python directory) is only a
+ `CMake custom targets <https://cmake.org/cmake/help/latest/command/add_custom_target.html>`_
+ to shortcut :code:`python setup.py build_ext --inplace` command.
+ No specific other options (:code:`-j8` for parallel, or even :code:`make clean`, ...) are
+ available.
+ But one can use :code:`python setup.py ...` specific options in the python directory:
+
+.. code-block:: bash
+
+ python setup.py clean --all # Clean former compilation
+ python setup.py build_ext -j 8 --inplace # Build in parallel
+
GUDHI Python module installation
================================
@@ -59,6 +73,17 @@ Or install it definitely in your Python packages folder:
# May require sudo or administrator privileges
make install
+.. note::
+
+ :code:`make install` is only a
+ `CMake custom targets <https://cmake.org/cmake/help/latest/command/add_custom_target.html>`_
+ to shortcut :code:`python setup.py install` command.
+ It does not take into account :code:`CMAKE_INSTALL_PREFIX`.
+ But one can use :code:`python setup.py install ...` specific options in the python directory:
+
+.. code-block:: bash
+
+ python setup.py install --prefix /home/gudhi # Install in /home/gudhi directory
Test suites
===========