summaryrefslogtreecommitdiff
path: root/src/python/setup.py.in
diff options
context:
space:
mode:
authorMarc Glisse <marc.glisse@inria.fr>2020-02-06 21:20:17 +0100
committerMarc Glisse <marc.glisse@inria.fr>2020-02-06 21:20:17 +0100
commit08b82e8a606a7fcd1219e7074cc2f15340090e59 (patch)
treeadbeb19efa3e208163f7b8ca95389e5563a72090 /src/python/setup.py.in
parent00c46d21df80c51a0c83e412230f4583a5803fc9 (diff)
Make pybind11 mandatory and simplify
The use of install_requires and setup_requires looks strange, I would expect cython in setup_requires, not install_requires. But setup_requires doesn't seem to work so well anyway.
Diffstat (limited to 'src/python/setup.py.in')
-rw-r--r--src/python/setup.py.in19
1 files changed, 3 insertions, 16 deletions
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 851188bd..d05e4675 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -12,6 +12,7 @@ from setuptools import setup, Extension
from Cython.Build import cythonize
from numpy import get_include as numpy_get_include
import sys
+import pybind11
__author__ = "Vincent Rouvreau"
__copyright__ = "Copyright (C) 2016 Inria"
@@ -27,20 +28,6 @@ library_dirs=[@GUDHI_PYTHON_LIBRARY_DIRS@]
include_dirs = [numpy_get_include(), '@CMAKE_CURRENT_SOURCE_DIR@/gudhi/', @GUDHI_PYTHON_INCLUDE_DIRS@]
runtime_library_dirs=[@GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS@]
-# Copied from https://github.com/pybind/python_example/blob/master/setup.py
-class get_pybind_include(object):
- """Helper class to determine the pybind11 include path
- The purpose of this class is to postpone importing pybind11
- until it is actually installed, so that the ``get_include()``
- method can be invoked. """
-
- def __init__(self, user=False):
- self.user = user
-
- def __str__(self):
- import pybind11
- return pybind11.get_include(self.user)
-
# Create ext_modules list from module list
ext_modules = []
for module in modules:
@@ -64,7 +51,7 @@ ext_modules.append(Extension(
language = 'c++',
include_dirs = include_dirs +
['@HERA_WASSERSTEIN_INCLUDE_DIR@',
- get_pybind_include(False), get_pybind_include(True)],
+ pybind11.get_include(False), pybind11.get_include(True)],
extra_compile_args=extra_compile_args + [@GUDHI_PYBIND11_EXTRA_COMPILE_ARGS@],
))
@@ -76,6 +63,6 @@ setup(
version='@GUDHI_VERSION@',
url='http://gudhi.gforge.inria.fr/',
ext_modules = ext_modules,
- install_requires = ['cython','numpy >= 1.9','pybind11',],
+ install_requires = ['cython','numpy >= 1.9',],
setup_requires = ['numpy >= 1.9','pybind11',],
)