summaryrefslogtreecommitdiff
path: root/src/python/setup.py.in
diff options
context:
space:
mode:
authorMarc Glisse <marc.glisse@inria.fr>2020-01-30 11:58:52 +0100
committerMarc Glisse <marc.glisse@inria.fr>2020-01-30 11:58:52 +0100
commit48952ee2ad76e2f4e5ada7f038ff88dee496272a (patch)
treef9ccf1cd58857eca88dc7dee3f29fbb6a9781b76 /src/python/setup.py.in
parent4c8e4549818bb033b148632abba4eae9ae9407c3 (diff)
Allow use of preinstalled Hera
Diffstat (limited to 'src/python/setup.py.in')
-rw-r--r--src/python/setup.py.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 08c46ced..851188bd 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -63,7 +63,7 @@ ext_modules.append(Extension(
sources = [source_dir + 'hera.cc'],
language = 'c++',
include_dirs = include_dirs +
- ['@CMAKE_SOURCE_DIR@/ext/hera/geom_matching/wasserstein/include',
+ ['@HERA_WASSERSTEIN_INCLUDE_DIR@',
get_pybind_include(False), get_pybind_include(True)],
extra_compile_args=extra_compile_args + [@GUDHI_PYBIND11_EXTRA_COMPILE_ARGS@],
))