summaryrefslogtreecommitdiff
path: root/src/python/setup.py.in
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-05-31 09:23:14 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-05-31 09:23:14 +0200
commit974a045acfdae6a9980d9473f9dc3ece716aa0e1 (patch)
tree8b4b154b61d8ab1310f43c4882b57a7bd8ec669a /src/python/setup.py.in
parentc4c2e870662528467ef130b3e6a9f76682a86fd1 (diff)
Add some fields for PyPi nice render
Diffstat (limited to 'src/python/setup.py.in')
-rw-r--r--src/python/setup.py.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index b9f4e3f0..55d2b604 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -68,7 +68,17 @@ setup(
author='GUDHI Editorial Board',
author_email='gudhi-contact@lists.gforge.inria.fr',
version='@GUDHI_VERSION@',
- url='http://gudhi.gforge.inria.fr/',
+ url='https://gudhi.inria.fr/',
+ project_urls={
+ 'Bug Tracker': 'https://github.com/GUDHI/gudhi-devel/issues',
+ 'Documentation': 'https://gudhi.inria.fr/python/latest/',
+ 'Source Code': 'https://github.com/GUDHI/gudhi-devel',
+ 'License': 'https://gudhi.inria.fr/licensing/'
+ },
+ description='The Gudhi library is an open source library for Computational Topology and Topological Data ' \
+ 'Analysis (TDA). It offers state-of-the-art algorithms to construct various types of simplicial complexes, ' \
+ 'data structures to represent them, and algorithms to compute geometric approximations of shapes and ' \
+ 'persistent homology.',
ext_modules = ext_modules,
install_requires = ['cython','numpy >= 1.9',],
setup_requires = ['numpy >= 1.9','pybind11',],