summaryrefslogtreecommitdiff
path: root/src/python
diff options
context:
space:
mode:
authorHind <hind.montassif@gmail.com>2021-04-15 09:46:27 +0200
committerHind <hind.montassif@gmail.com>2021-04-15 09:46:27 +0200
commit0e11a3a2232770b0526918d2b543848abd092254 (patch)
treefa99c1079938185419d6ff387d7c774d3d671ecc /src/python
parent7e05e915adc1be285e04eb00d3ab7ba1b797f38d (diff)
Set Cython language level to remove warning
Diffstat (limited to 'src/python')
-rw-r--r--src/python/gudhi/simplex_tree.pyx2
-rw-r--r--src/python/setup.py.in5
2 files changed, 3 insertions, 4 deletions
diff --git a/src/python/gudhi/simplex_tree.pyx b/src/python/gudhi/simplex_tree.pyx
index d7991417..be08a3a1 100644
--- a/src/python/gudhi/simplex_tree.pyx
+++ b/src/python/gudhi/simplex_tree.pyx
@@ -11,7 +11,7 @@ from cython.operator import dereference, preincrement
from libc.stdint cimport intptr_t
import numpy
from numpy import array as np_array
-cimport simplex_tree
+cimport gudhi.simplex_tree
__author__ = "Vincent Rouvreau"
__copyright__ = "Copyright (C) 2016 Inria"
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 98d058fc..65f5446e 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -41,10 +41,9 @@ for module in cython_modules:
libraries=libraries,
library_dirs=library_dirs,
include_dirs=include_dirs,
- runtime_library_dirs=runtime_library_dirs,
- cython_directives = {'language_level': str(sys.version_info[0])},))
+ runtime_library_dirs=runtime_library_dirs,))
-ext_modules = cythonize(ext_modules)
+ext_modules = cythonize(ext_modules, compiler_directives={'language_level': str(sys.version_info[0])})
for module in pybind11_modules:
my_include_dirs = include_dirs + [pybind11.get_include(False), pybind11.get_include(True)]