summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-30 20:53:45 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-30 20:53:45 +0000
commitd0aa6ea5b543c4692f6e42d12252b03d5e43a255 (patch)
tree9e4f8441f968194777a2c0ec6d774f33c149a21c /src
parent4b6d52d1a1b16f4026b9eb98495ac6fe1aa95281 (diff)
Add install requires matplotlib and numpy in setup.py
Add Python test fail explanation git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/python_2.1.0_fix_vincent@3494 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 1bac18228a22ea718bb8c77d38efdf84f9b228eb
Diffstat (limited to 'src')
-rw-r--r--src/cython/doc/installation.rst3
-rw-r--r--src/cython/setup.py.in7
2 files changed, 10 insertions, 0 deletions
diff --git a/src/cython/doc/installation.rst b/src/cython/doc/installation.rst
index c182f176..28d9dba2 100644
--- a/src/cython/doc/installation.rst
+++ b/src/cython/doc/installation.rst
@@ -43,6 +43,9 @@ following command in a terminal:
export PYTHONPATH='$PYTHONPATH:/path-to-gudhi/build/cython'
ctest -R py_test
+If tests fail, please try to :code:`import gudhi` and check the errors.
+The problem can come from a third-party library bad link or installation.
+
Documentation
=============
diff --git a/src/cython/setup.py.in b/src/cython/setup.py.in
index c767e93d..eda1ee04 100644
--- a/src/cython/setup.py.in
+++ b/src/cython/setup.py.in
@@ -46,4 +46,11 @@ setup(
version='@GUDHI_VERSION@',
url='http://gudhi.gforge.inria.fr/',
ext_modules = cythonize(gudhi),
+
+ #install_requires = required,
+ install_requires = [
+ "matplotlib",
+ "numpy",
+ "cython",
+ ],
)