summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorMarc Glisse <marc.glisse@inria.fr>2020-11-01 21:04:21 +0100
committerMarc Glisse <marc.glisse@inria.fr>2020-11-01 21:08:19 +0100
commit20c50414163aabe6216c638b25c9568cfd1db458 (patch)
tree85cd7c97683b711350b843170450ce5911417290 /src
parent7d8e6d025436f269bc2e09292f118c4d8a035660 (diff)
The example does not need CGAL/eigen anymore.
I had done a search and replace without checking. I don't understand why there are "install" directives for examples...
Diffstat (limited to 'src')
-rw-r--r--src/Subsampling/example/CMakeLists.txt5
-rw-r--r--src/common/doc/installation.h4
2 files changed, 3 insertions, 6 deletions
diff --git a/src/Subsampling/example/CMakeLists.txt b/src/Subsampling/example/CMakeLists.txt
index fb6875e1..bb02b37d 100644
--- a/src/Subsampling/example/CMakeLists.txt
+++ b/src/Subsampling/example/CMakeLists.txt
@@ -3,7 +3,6 @@ project(Subsampling_examples)
if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
add_executable(Subsampling_example_pick_n_random_points example_pick_n_random_points.cpp)
add_executable(Subsampling_example_choose_n_farthest_points example_choose_n_farthest_points.cpp)
- add_executable(Subsampling_example_custom_distance example_custom_distance.cpp)
add_executable(Subsampling_example_sparsify_point_set example_sparsify_point_set.cpp)
target_link_libraries(Subsampling_example_sparsify_point_set ${CGAL_LIBRARY})
@@ -16,7 +15,9 @@ if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
install(TARGETS Subsampling_example_pick_n_random_points DESTINATION bin)
install(TARGETS Subsampling_example_choose_n_farthest_points DESTINATION bin)
- install(TARGETS Subsampling_example_custom_distance DESTINATION bin)
install(TARGETS Subsampling_example_sparsify_point_set DESTINATION bin)
endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+
+add_executable(Subsampling_example_custom_distance example_custom_distance.cpp)
+install(TARGETS Subsampling_example_custom_distance DESTINATION bin)
diff --git a/src/common/doc/installation.h b/src/common/doc/installation.h
index a6b9292b..c2e63a24 100644
--- a/src/common/doc/installation.h
+++ b/src/common/doc/installation.h
@@ -113,8 +113,6 @@ make doxygen
* Spatial_searching/example_spatial_searching.cpp</a>
* \li <a href="_subsampling_2example_choose_n_farthest_points_8cpp-example.html">
* Subsampling/example_choose_n_farthest_points.cpp</a>
- * \li <a href="_subsampling_2example_custom_distance_8cpp-example.html">
- * Subsampling/example_custom_distance.cpp</a>
* \li <a href="_subsampling_2example_pick_n_random_points_8cpp-example.html">
* Subsampling/example_pick_n_random_points.cpp</a>
* \li <a href="_subsampling_2example_sparsify_point_set_8cpp-example.html">
@@ -153,8 +151,6 @@ make doxygen
* Spatial_searching/example_spatial_searching.cpp</a>
* \li <a href="_subsampling_2example_choose_n_farthest_points_8cpp-example.html">
* Subsampling/example_choose_n_farthest_points.cpp</a>
- * \li <a href="_subsampling_2example_custom_distance_8cpp-example.html">
- * Subsampling/example_custom_distance.cpp</a>
* \li <a href="_subsampling_2example_pick_n_random_points_8cpp-example.html">
* Subsampling/example_pick_n_random_points.cpp</a>
* \li <a href="_subsampling_2example_sparsify_point_set_8cpp-example.html">