summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-04-10 13:42:31 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-04-10 13:42:31 +0000
commit2334cb2704e84792f3972ba7d3b45a7b9ee75f67 (patch)
treeae88e18468240cbf71a90567dbbadb5f8ce67e2e /src
parent202bf9722358355c12e85c0718da567ce9d9a6ae (diff)
mac osx version is 10.12 and not 10.9 (cf. mail Bertrand Michel)
Add text for Windows Python 3.X installation and forinstallation with several Python installed on the system. git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/ST_cythonize@2324 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 939d5d4a94c2430de11b3dcbc29a65aad4bfd885
Diffstat (limited to 'src')
-rw-r--r--src/cython/CMakeLists.txt4
-rw-r--r--src/cython/doc/installation.rst15
2 files changed, 12 insertions, 7 deletions
diff --git a/src/cython/CMakeLists.txt b/src/cython/CMakeLists.txt
index a3a3ebc8..51c208aa 100644
--- a/src/cython/CMakeLists.txt
+++ b/src/cython/CMakeLists.txt
@@ -140,8 +140,8 @@ if(CYTHON_PATH)
# Specific for Mac
if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
- set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-mmacosx-version-min=10.9', ")
- set(GUDHI_CYTHON_EXTRA_LINK_ARGS "${GUDHI_CYTHON_EXTRA_LINK_ARGS}'-mmacosx-version-min=10.9', ")
+ set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-mmacosx-version-min=10.12', ")
+ set(GUDHI_CYTHON_EXTRA_LINK_ARGS "${GUDHI_CYTHON_EXTRA_LINK_ARGS}'-mmacosx-version-min=10.12', ")
endif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
# Loop on INCLUDE_DIRECTORIES PROPERTY
diff --git a/src/cython/doc/installation.rst b/src/cython/doc/installation.rst
index 5b1e545d..f818366b 100644
--- a/src/cython/doc/installation.rst
+++ b/src/cython/doc/installation.rst
@@ -4,12 +4,19 @@ Installation
Compiling
*********
-The library uses c++11 and requires `Boost <http://www.boost.org/>`_ with version
-1.48.0 or more recent. It is a multi-platform library and compiles on Linux,
-Mac OSX and Visual Studio 2015.
+The library uses c++11 and requires `Boost <http://www.boost.org/>`_ with
+version 1.48.0 or more recent. It is a multi-platform library and compiles on
+Linux, Mac OSX and Visual Studio 2015.
It also requires cmake to generate makefiles, and cython to compile the
library.
+On `Windows <https://wiki.python.org/moin/WindowsCompilers>`_ , only Python
+3.5 and 3.6 are available because of required Visual Studio version.
+
+On other systems, if you have several Python/cython installed, the version 2.X
+will be used by default, but you can force it by adding
+:code:`-DPython_ADDITIONAL_VERSIONS=3` to the cmake command.
+
GUDHI Cythonization
===================
@@ -23,8 +30,6 @@ To build the GUDHI cython module, run the following commands in a terminal:
cmake ..
make cython
-A list of examples is available here.
-
Test suites
===========