summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-12 10:00:10 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-12 10:00:10 +0100
commit38f0ff98cf6da1e882b6b44fc3ed7b3d310fb91f (patch)
treecd5aeb1fc71bb14ff95015e6345efc3e6cada158 /src
parent94118b7c5c723bf62dcdafd404d492e8d78d0019 (diff)
Doc review: use ctest directly and provide options suggestions
Diffstat (limited to 'src')
-rw-r--r--src/python/doc/installation.rst22
1 files changed, 10 insertions, 12 deletions
diff --git a/src/python/doc/installation.rst b/src/python/doc/installation.rst
index 3553ae51..50a697c7 100644
--- a/src/python/doc/installation.rst
+++ b/src/python/doc/installation.rst
@@ -83,32 +83,30 @@ Or install it definitely in your Python packages folder:
.. code-block:: bash
- python setup.py install --prefix /home/gudhi # Install in /home/gudhi directory
+ python setup.py install --prefix /home/gudhi # Install in /home/gudhi directory
Test suites
===========
-To test your build, `py.test <http://doc.pytest.org>`_ is optional. Run the
-following command in a terminal:
+To test your build, `py.test <http://doc.pytest.org>`_ is required. Run the
+following `Ctest <https://cmake.org/cmake/help/latest/manual/ctest.1.html>`_
+(CMake test driver program) command in a terminal:
.. code-block:: bash
cd /path-to-gudhi/build/python
# For windows, you have to set PYTHONPATH environment variable
export PYTHONPATH='$PYTHONPATH:/path-to-gudhi/build/python'
- make test
+ ctest
-`make test` is using
-`Ctest <https://cmake.org/cmake/help/latest/manual/ctest.1.html>`_ (CMake test
-driver program). If some of the tests are failing, plend send us the result of
-the following command:
+.. note::
+
+ One can use :code:`ctest` specific options in the python directory:
.. code-block:: bash
- cd /path-to-gudhi/build/python
- # For windows, you have to set PYTHONPATH environment variable
- export PYTHONPATH='$PYTHONPATH:/path-to-gudhi/build/python'
- ctest --output-on-failure
+ # Launch tests in parallel on 8 cores and set failing tests in verbose mode
+ ctest -j 8 --output-on-failure
Debugging issues
================