summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-16 10:47:34 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-12-16 10:47:34 +0100
commit7b2ac5ccd53ec8988854e5ac2c3c20176e0c24ed (patch)
tree8384410062b0fa97a32a6894642d17d5d5f9d6c2 /src
parentaa93957d37a1f8e0a2d25af27ad87eb6b8eb84c3 (diff)
Fix MPFR when CGAL is not header only
Diffstat (limited to 'src')
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 1704f491..b558d4c4 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -169,6 +169,10 @@ if(PYTHONINTERP_FOUND)
add_gudhi_debug_info("MPFR_LIBRARIES = ${MPFR_LIBRARIES}")
set(GUDHI_PYTHON_EXTRA_COMPILE_ARGS "${GUDHI_PYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_USE_MPFR', ")
add_GUDHI_PYTHON_lib("${MPFR_LIBRARIES}")
+ # In case CGAL is not header only, all MPFR variables are set except MPFR_LIBRARIES_DIR - Just set it
+ if(NOT MPFR_LIBRARIES_DIR)
+ get_filename_component(MPFR_LIBRARIES_DIR ${MPFR_LIBRARIES} PATH)
+ endif(NOT MPFR_LIBRARIES_DIR)
set(GUDHI_PYTHON_LIBRARY_DIRS "${GUDHI_PYTHON_LIBRARY_DIRS}'${MPFR_LIBRARIES_DIR}', ")
message("** Add mpfr ${MPFR_LIBRARIES}")
endif(MPFR_FOUND)