summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-18 21:54:35 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-18 21:54:35 +0200
commita38d6085a8dd8c76a0c6db593a4fc6891e253cdb (patch)
tree46838a1678a2a4b14201d6c3d75433ac00ba6edc /src
parent30e2090066fae2734828c78fdd070a2559da135f (diff)
Separate the 2 examples as one requires also Eigen3
Diffstat (limited to 'src')
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
index 8987ac39..3d65963a 100644
--- a/src/Bottleneck_distance/example/CMakeLists.txt
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -2,20 +2,24 @@ project(Bottleneck_distance_examples)
if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
add_executable (bottleneck_basic_example bottleneck_basic_example.cpp)
+
+ if (TBB_FOUND)
+ target_link_libraries(bottleneck_basic_example ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+
+ add_test(NAME Bottleneck_distance_example_basic COMMAND $<TARGET_FILE:bottleneck_basic_example>)
+
+endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
add_executable (alpha_rips_persistence_bottleneck_distance alpha_rips_persistence_bottleneck_distance.cpp)
target_link_libraries(alpha_rips_persistence_bottleneck_distance ${Boost_PROGRAM_OPTIONS_LIBRARY})
if (TBB_FOUND)
target_link_libraries(alpha_rips_persistence_bottleneck_distance ${TBB_LIBRARIES})
- target_link_libraries(bottleneck_basic_example ${TBB_LIBRARIES})
endif(TBB_FOUND)
- add_test(NAME Bottleneck_distance_example_basic COMMAND $<TARGET_FILE:bottleneck_basic_example>)
add_test(NAME Bottleneck_distance_example_alpha_rips_persistence_bottleneck
COMMAND $<TARGET_FILE:alpha_rips_persistence_bottleneck_distance>
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.15" "-m" "0.12" "-d" "3" "-p" "3")
-
- install(TARGETS bottleneck_basic_example DESTINATION bin)
- install(TARGETS alpha_rips_persistence_bottleneck_distance DESTINATION bin)
-
-endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)