summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2019-02-14 16:57:30 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2019-02-14 16:57:30 +0000
commitd7216fffe2a7fb3b15dcb84a4d5464968ae4a436 (patch)
treec20084a7932f41a0dbf42896af97c2c552c2a12c /src
parent68c4ffe856b8de030bb4c7c75bccce7082d5478c (diff)
Fix https://gitlab.inria.fr/GUDHI/gudhi-devel/issues/28
[python - install] make install does not install properly Use 'python setup.py install' command instead of copying files git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@4108 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 652d3597897aa3e7d1df97083cc3e2e4ae14f090
Diffstat (limited to 'src')
-rw-r--r--src/cython/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/cython/CMakeLists.txt b/src/cython/CMakeLists.txt
index 97859c98..480332d7 100644
--- a/src/cython/CMakeLists.txt
+++ b/src/cython/CMakeLists.txt
@@ -215,12 +215,7 @@ if(PYTHONINTERP_FOUND)
add_custom_target(cython ALL DEPENDS gudhi.so
COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
- # For installation purpose
- # TODO(VR) : files matching pattern mechanism is copying all cython directory
- install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}" DESTINATION "${PYTHON_SITE_PACKAGES}/" FILES_MATCHING
- PATTERN "*.so"
- PATTERN "*.dylib"
- PATTERN "*.pyd")
+ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
# Test examples
if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)