summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 14:29:41 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 14:29:41 +0200
commit599d68cd916f533bdb66dd9e684dd5703233b6bb (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /utilities/Persistence_representations/CMakeLists.txt
parenta2e642954ae39025e041471d486ecbac25dff440 (diff)
Delete all files in order to incorporate upstream's move to git.
Diffstat (limited to 'utilities/Persistence_representations/CMakeLists.txt')
-rw-r--r--utilities/Persistence_representations/CMakeLists.txt59
1 files changed, 0 insertions, 59 deletions
diff --git a/utilities/Persistence_representations/CMakeLists.txt b/utilities/Persistence_representations/CMakeLists.txt
deleted file mode 100644
index fc51b1d6..00000000
--- a/utilities/Persistence_representations/CMakeLists.txt
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copy files, otherwise result files are created in sources
-file(COPY "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
-file(COPY "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
-
-function(add_persistence_representation_creation_utility creation_utility)
- add_executable ( ${creation_utility} ${creation_utility}.cpp )
-
- # as the function is called in a subdirectory level, need to '../' to find persistence files
- # ARGN will add all the other arguments (except creation_utility) sent to the CMake functions
- add_test(NAME Persistence_representation_utilities_${creation_utility} COMMAND $<TARGET_FILE:${creation_utility}>
- ${ARGN} "${CMAKE_CURRENT_BINARY_DIR}/../first.pers"
- "${CMAKE_CURRENT_BINARY_DIR}/../second.pers")
-
- install(TARGETS ${creation_utility} DESTINATION bin)
-endfunction(add_persistence_representation_creation_utility)
-
-function(add_persistence_representation_plot_utility plot_utility tool_extension)
- add_executable ( ${plot_utility} ${plot_utility}.cpp )
-
- # as the function is called in a subdirectory level, need to '../' to find persistence heat maps files
- add_test(NAME Persistence_representation_utilities_${plot_utility}_first COMMAND $<TARGET_FILE:${plot_utility}>
- "${CMAKE_CURRENT_BINARY_DIR}/../first.pers${tool_extension}")
- #add_test(NAME Persistence_representation_utilities_${plot_utility}_second COMMAND $<TARGET_FILE:${plot_utility}>
- # "${CMAKE_CURRENT_BINARY_DIR}/../second.pers${tool_extension}")
- if(GNUPLOT_PATH)
- add_test(NAME Persistence_representation_utilities_${plot_utility}_first_gnuplot COMMAND ${GNUPLOT_PATH}
- "-e" "load '${CMAKE_CURRENT_BINARY_DIR}/../first.pers${tool_extension}_GnuplotScript'")
- #add_test(NAME Persistence_representation_utilities_${plot_utility}_second_gnuplot COMMAND ${GNUPLOT_PATH}
- # "-e" "load '${CMAKE_CURRENT_BINARY_DIR}/../second.pers${tool_extension}_GnuplotScript'")
- endif()
-
- install(TARGETS ${plot_utility} DESTINATION bin)
-endfunction(add_persistence_representation_plot_utility)
-
-function(add_persistence_representation_function_utility function_utility tool_extension)
- add_executable ( ${function_utility} ${function_utility}.cpp )
-
- # ARGV2 is an optional argument
- if (${ARGV2})
- # as the function is called in a subdirectory level, need to '../' to find persistence heat maps files
- add_test(NAME Persistence_representation_utilities_${function_utility} COMMAND $<TARGET_FILE:${function_utility}>
- "${ARGV2}"
- "${CMAKE_CURRENT_BINARY_DIR}/../first.pers${tool_extension}"
- "${CMAKE_CURRENT_BINARY_DIR}/../second.pers${tool_extension}")
- else()
- # as the function is called in a subdirectory level, need to '../' to find persistence heat maps files
- add_test(NAME Persistence_representation_utilities_${function_utility} COMMAND $<TARGET_FILE:${function_utility}>
- "${CMAKE_CURRENT_BINARY_DIR}/../first.pers${tool_extension}"
- "${CMAKE_CURRENT_BINARY_DIR}/../second.pers${tool_extension}")
- endif()
-
- install(TARGETS ${function_utility} DESTINATION bin)
-endfunction(add_persistence_representation_function_utility)
-
-add_subdirectory(persistence_heat_maps)
-add_subdirectory(persistence_intervals)
-add_subdirectory(persistence_landscapes)
-add_subdirectory(persistence_landscapes_on_grid)
-add_subdirectory(persistence_vectors)