summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-02-02 13:51:45 +0100
committerGard Spreemann <gspreemann@gmail.com>2018-02-02 13:51:45 +0100
commit9899ae167f281d10b1684dfcd02c6838c5bf28df (patch)
treeceda62a40a9a8f731298832b1b4ab44ab0dd3a10 /utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
parent866f6ce614e9c09c97fed12c8c0c2c9fb84fad3f (diff)
GUDHI 2.1.0 as released by upstream in a tarball.upstream/2.1.0
Diffstat (limited to 'utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt')
-rw-r--r--utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt b/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
new file mode 100644
index 00000000..c5ea4bbf
--- /dev/null
+++ b/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.6)
+project(Persistence_representations_lanscapes_on_grid_utilities)
+
+# Need to set grid min and max for further average, distance and scalar_product
+add_persistence_representation_creation_utility(create_landscapes_on_grid "100" "0" "35" "-1")
+
+add_persistence_representation_plot_utility(plot_landscapes_on_grid ".g_land")
+
+add_persistence_representation_function_utility(average_landscapes_on_grid ".g_land")
+add_persistence_representation_function_utility(compute_distance_of_landscapes_on_grid ".g_land" "1")
+add_persistence_representation_function_utility(compute_scalar_product_of_landscapes_on_grid ".g_land")