summaryrefslogtreecommitdiff
path: root/.circleci/config.yml
diff options
context:
space:
mode:
Diffstat (limited to '.circleci/config.yml')
-rw-r--r--.circleci/config.yml20
1 files changed, 18 insertions, 2 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index d95b8d36..f6a875dd 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -1,7 +1,11 @@
version: 2.0
jobs:
+
+### With all third parties
+
examples:
docker:
+ # cf. https://github.com/GUDHI/gudhi-deploy/blob/main/Dockerfile_for_circleci_image
- image: gudhi/ci_for_gudhi:latest
steps:
- checkout
@@ -86,17 +90,26 @@ jobs:
mkdir build
cd build
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF -DUSER_VERSION_DIR=version ..
+ make user_version
+ cd version
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF ..
make doxygen 2>&1 | tee dox.log
grep warning dox.log
- cp dox.log version/doc/html/
- cp -R version/doc/html /tmp/doxygen
+ cp dox.log html/
+ cp -R html /tmp/doxygen
- store_artifacts:
path: /tmp/doxygen
destination: doxygen
+
+### With all third parties, except CGAL and Eigen
+
examples_without_cgal_eigen:
docker:
+ # cf. https://github.com/GUDHI/gudhi-deploy/blob/main/Dockerfile_for_circleci_image_without_cgal
- image: gudhi/ci_for_gudhi_wo_cgal:latest
steps:
- checkout
@@ -154,6 +167,9 @@ jobs:
python3 setup.py build_ext --inplace
ctest --output-on-failure
+
+### With all third parties, except CGAL
+
examples_without_cgal:
docker:
- image: gudhi/ci_for_gudhi_wo_cgal:latest