summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/cython/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/cython/CMakeLists.txt b/src/cython/CMakeLists.txt
index 97859c98..480332d7 100644
--- a/src/cython/CMakeLists.txt
+++ b/src/cython/CMakeLists.txt
@@ -215,12 +215,7 @@ if(PYTHONINTERP_FOUND)
add_custom_target(cython ALL DEPENDS gudhi.so
COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
- # For installation purpose
- # TODO(VR) : files matching pattern mechanism is copying all cython directory
- install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}" DESTINATION "${PYTHON_SITE_PACKAGES}/" FILES_MATCHING
- PATTERN "*.so"
- PATTERN "*.dylib"
- PATTERN "*.pyd")
+ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
# Test examples
if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)