summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0005-Support-QGLViewer-2.7.patch26
-rw-r--r--debian/patches/series1
3 files changed, 33 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8a7777b8..1d4c5eb2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gudhi (3.6.0+dfsg-4) unstable; urgency=medium
+
+ * Add patch to support QGLViewer >=2.7. (Closes: 1024061)
+
+ -- Gard Spreemann <gspr@nonempty.org> Mon, 14 Nov 2022 17:30:15 +0100
+
gudhi (3.6.0+dfsg-3) unstable; urgency=medium
* Bump CGAL dependency to >=5.5.1, allowing us to drop the CGAL 5.5
diff --git a/debian/patches/0005-Support-QGLViewer-2.7.patch b/debian/patches/0005-Support-QGLViewer-2.7.patch
new file mode 100644
index 00000000..2f367d5f
--- /dev/null
+++ b/debian/patches/0005-Support-QGLViewer-2.7.patch
@@ -0,0 +1,26 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Mon, 14 Nov 2022 17:28:23 +0100
+Subject: Support QGLViewer >=2.7
+
+This is Marc Glisse's commit 1e71120bdacb6f5ec4c90fb4c1365f76ecea7ff9
+proposed upstream.
+---
+ src/GudhUI/view/Viewer.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/GudhUI/view/Viewer.cpp b/src/GudhUI/view/Viewer.cpp
+index 6b17c83..2c00f86 100644
+--- a/src/GudhUI/view/Viewer.cpp
++++ b/src/GudhUI/view/Viewer.cpp
+@@ -31,7 +31,11 @@ void Viewer::set_bounding_box(const Point_3 & lower_left, const Point_3 & upper_
+ }
+
+ void Viewer::update_GL() {
++#if QGLVIEWER_VERSION >= 0x020700
++ this->update();
++#else
+ this->updateGL();
++#endif
+ }
+
+ void Viewer::init_scene() {
diff --git a/debian/patches/series b/debian/patches/series
index ab3337cf..3f3da71a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
0002-Use-system-MathJax.patch
0003-Offline-header-for-docs.patch
0004-Disable-Sphinx.patch
+0005-Support-QGLViewer-2.7.patch