summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/Bitmap_cubical_complex/utilities/CMakeLists.txt20
-rw-r--r--src/Bitmap_cubical_complex/utilities/README22
-rw-r--r--src/Bitmap_cubical_complex/utilities/cubical_complex_persistence.cpp (renamed from src/Bitmap_cubical_complex/utilities/Bitmap_cubical_complex.cpp)0
-rw-r--r--src/Bitmap_cubical_complex/utilities/periodic_cubical_complex_persistence.cpp (renamed from src/Bitmap_cubical_complex/utilities/Bitmap_cubical_complex_periodic_boundary_conditions.cpp)0
-rw-r--r--src/Bottleneck_distance/utilities/CMakeLists.txt8
-rw-r--r--src/Bottleneck_distance/utilities/bottleneck_distance.cpp (renamed from src/Bottleneck_distance/utilities/bottleneck_read_file.cpp)0
-rw-r--r--src/common/doc/main_page.h12
7 files changed, 28 insertions, 34 deletions
diff --git a/src/Bitmap_cubical_complex/utilities/CMakeLists.txt b/src/Bitmap_cubical_complex/utilities/CMakeLists.txt
index f0f80059..676a730a 100644
--- a/src/Bitmap_cubical_complex/utilities/CMakeLists.txt
+++ b/src/Bitmap_cubical_complex/utilities/CMakeLists.txt
@@ -1,29 +1,29 @@
cmake_minimum_required(VERSION 2.6)
project(Bitmap_cubical_complex_utilities)
-add_executable ( Bitmap_cubical_complex Bitmap_cubical_complex.cpp )
+add_executable ( cubical_complex_persistence cubical_complex_persistence.cpp )
if (TBB_FOUND)
- target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
+ target_link_libraries(cubical_complex_persistence ${TBB_LIBRARIES})
endif()
-add_test(NAME Bitmap_cubical_complex_utility_persistence_one_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
+add_test(NAME Bitmap_cubical_complex_utility_persistence_one_sphere COMMAND $<TARGET_FILE:cubical_complex_persistence>
"${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt")
-add_test(NAME Bitmap_cubical_complex_utility_persistence_two_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
+add_test(NAME Bitmap_cubical_complex_utility_persistence_two_sphere COMMAND $<TARGET_FILE:cubical_complex_persistence>
"${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt")
-add_executable ( Bitmap_cubical_complex_periodic_boundary_conditions Bitmap_cubical_complex_periodic_boundary_conditions.cpp )
+add_executable ( periodic_cubical_complex_persistence periodic_cubical_complex_persistence.cpp )
if (TBB_FOUND)
- target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${TBB_LIBRARIES})
+ target_link_libraries(periodic_cubical_complex_persistence ${TBB_LIBRARIES})
endif()
add_test(NAME Bitmap_cubical_complex_utility_periodic_boundary_conditions_2d_torus
- COMMAND $<TARGET_FILE:Bitmap_cubical_complex_periodic_boundary_conditions>
+ COMMAND $<TARGET_FILE:periodic_cubical_complex_persistence>
"${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt")
add_test(NAME Bitmap_cubical_complex_utility_periodic_boundary_conditions_3d_torus
- COMMAND $<TARGET_FILE:Bitmap_cubical_complex_periodic_boundary_conditions>
+ COMMAND $<TARGET_FILE:periodic_cubical_complex_persistence>
"${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt")
-install(TARGETS Bitmap_cubical_complex DESTINATION bin)
-install(TARGETS Bitmap_cubical_complex_periodic_boundary_conditions DESTINATION bin)
+install(TARGETS cubical_complex_persistence DESTINATION bin)
+install(TARGETS periodic_cubical_complex_persistence DESTINATION bin)
diff --git a/src/Bitmap_cubical_complex/utilities/README b/src/Bitmap_cubical_complex/utilities/README
index d9085635..e7c10083 100644
--- a/src/Bitmap_cubical_complex/utilities/README
+++ b/src/Bitmap_cubical_complex/utilities/README
@@ -1,24 +1,18 @@
# Bitmap_cubical_complex #
-## `Bitmap_cubical_complex` ##
+## `cubical_complex_persistence` ##
This program computes persistent homology, by using the Bitmap_cubical_complex class, of cubical complexes provided in text files in Perseus style. The only number in the first line is a dimension D of a bitmap. In the lines I between 2 and D+1 there are numbers of top dimensional cells in the direction I. Let N denote product of the numbers in the lines between 2 and D. In the lines D+2 to D+2+N there are filtrations of top dimensional cells. We assume that the cells are in the lexicographical order.
-Examples:
+Example:
-* Create a Cubical Complex from the Perseus style file CubicalOneSphere.txt, computes Persistence cohomology from it and writes the results in a persistence file:
-`Bitmap_cubical_complex data/bitmap/CubicalOneSphere.txt`
+* Create a Cubical Complex from the Perseus style file `CubicalTwoSphere.txt`, computes Persistence cohomology from it and writes the results in a persistence file `CubicalTwoSphere.txt_persistence`:
+`cubical_complex_persistence data/bitmap/CubicalTwoSphere.txt`
-* Create a Cubical Complex from the Perseus style file CubicalTwoSphere.txt, computes Persistence cohomology from it and writes the results in a persistence file:
-`Bitmap_cubical_complex data/bitmap/CubicalTwoSphere.txt`
-
-## `Bitmap_cubical_complex_periodic_boundary_conditions` ##
+## `periodic_cubical_complex_persistence` ##
Same as above, but with periodic boundary conditions.
-Examples:
-
-* Create a Periodical Cubical Complex from the Perseus style file 2d_torus.txt, computes Persistence cohomology from it and writes the results in a persistence file:
-`Bitmap_cubical_complex_periodic_boundary_conditions.exe data/bitmap/2d_torus.txt`
+Example:
-* Create a Periodical Cubical Complex from the Perseus style file 3d_torus.txt, computes Persistence cohomology from it and writes the results in a persistence file:
-`Bitmap_cubical_complex_periodic_boundary_conditions.exe data/bitmap/3d_torus.txt`
+* Create a Periodical Cubical Complex from the Perseus style file `3d_torus.txt`, computes Persistence cohomology from it and writes the results in a persistence file `3d_torus.txt_persistence`:
+`periodic_cubical_complex_persistence data/bitmap/3d_torus.txt`
diff --git a/src/Bitmap_cubical_complex/utilities/Bitmap_cubical_complex.cpp b/src/Bitmap_cubical_complex/utilities/cubical_complex_persistence.cpp
index 9d1bc08c..9d1bc08c 100644
--- a/src/Bitmap_cubical_complex/utilities/Bitmap_cubical_complex.cpp
+++ b/src/Bitmap_cubical_complex/utilities/cubical_complex_persistence.cpp
diff --git a/src/Bitmap_cubical_complex/utilities/Bitmap_cubical_complex_periodic_boundary_conditions.cpp b/src/Bitmap_cubical_complex/utilities/periodic_cubical_complex_persistence.cpp
index c812cb3a..c812cb3a 100644
--- a/src/Bitmap_cubical_complex/utilities/Bitmap_cubical_complex_periodic_boundary_conditions.cpp
+++ b/src/Bitmap_cubical_complex/utilities/periodic_cubical_complex_persistence.cpp
diff --git a/src/Bottleneck_distance/utilities/CMakeLists.txt b/src/Bottleneck_distance/utilities/CMakeLists.txt
index 063b6ae3..d19e3b1c 100644
--- a/src/Bottleneck_distance/utilities/CMakeLists.txt
+++ b/src/Bottleneck_distance/utilities/CMakeLists.txt
@@ -2,15 +2,15 @@ cmake_minimum_required(VERSION 2.6)
project(Bottleneck_distance_utilities)
if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable (bottleneck_read_file bottleneck_read_file.cpp)
+ add_executable (bottleneck_distance bottleneck_distance.cpp)
if (TBB_FOUND)
- target_link_libraries(bottleneck_read_file ${TBB_LIBRARIES})
+ target_link_libraries(bottleneck_distance ${TBB_LIBRARIES})
endif(TBB_FOUND)
add_test(NAME Bottleneck_distance_utilities_Bottleneck_read_file
- COMMAND $<TARGET_FILE:bottleneck_read_file>
+ COMMAND $<TARGET_FILE:bottleneck_distance>
"${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
- install(TARGETS bottleneck_read_file DESTINATION bin)
+ install(TARGETS bottleneck_distance DESTINATION bin)
endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
diff --git a/src/Bottleneck_distance/utilities/bottleneck_read_file.cpp b/src/Bottleneck_distance/utilities/bottleneck_distance.cpp
index 9dd52b31..9dd52b31 100644
--- a/src/Bottleneck_distance/utilities/bottleneck_read_file.cpp
+++ b/src/Bottleneck_distance/utilities/bottleneck_distance.cpp
diff --git a/src/common/doc/main_page.h b/src/common/doc/main_page.h
index 34d3893d..72ef191d 100644
--- a/src/common/doc/main_page.h
+++ b/src/common/doc/main_page.h
@@ -328,7 +328,7 @@ make doxygen
* \li <a href="_bottleneck_distance_2bottleneck_basic_example_8cpp-example.html">
* Bottleneck_distance/bottleneck_basic_example.cpp</a>
* \li <a href="_bottleneck_distance_2bottleneck_read_file_8cpp-example.html">
- * Bottleneck_distance/bottleneck_read_file.cpp</a>
+ * Bottleneck_distance/bottleneck_distance.cpp</a>
* \li <a href="_spatial_searching_2example_spatial_searching_8cpp-example.html">
* Spatial_searching/example_spatial_searching.cpp</a>
* \li <a href="_subsampling_2example_choose_n_farthest_points_8cpp-example.html">
@@ -411,9 +411,9 @@ make doxygen
* \li <a href="_alpha_complex_2weighted_alpha_complex_3d_persistence_8cpp-example.html">
* Alpha_complex/weighted_alpha_complex_3d_persistence.cpp</a>
* \li <a href="_bitmap_cubical_complex_2_bitmap_cubical_complex_8cpp-example.html">
- * Bitmap_cubical_complex/Bitmap_cubical_complex.cpp</a>
+ * Bitmap_cubical_complex/cubical_complex_persistence.cpp</a>
* \li <a href="_bitmap_cubical_complex_2_bitmap_cubical_complex_periodic_boundary_conditions_8cpp-example.html">
- * Bitmap_cubical_complex/Bitmap_cubical_complex_periodic_boundary_conditions.cpp</a>
+ * Bitmap_cubical_complex/periodic_cubical_complex_persistence.cpp</a>
* \li <a href="_bitmap_cubical_complex_2_random_bitmap_cubical_complex_8cpp-example.html">
* Bitmap_cubical_complex/Random_bitmap_cubical_complex.cpp</a>
* \li <a href="_simplex_tree_2simple_simplex_tree_8cpp-example.html">
@@ -491,9 +491,9 @@ make doxygen
* @example Alpha_complex/weighted_alpha_complex_3d_persistence.cpp
* @example Bottleneck_distance/alpha_rips_persistence_bottleneck_distance.cpp
* @example Bottleneck_distance/bottleneck_basic_example.cpp
- * @example Bottleneck_distance/bottleneck_read_file.cpp
- * @example Bitmap_cubical_complex/Bitmap_cubical_complex.cpp
- * @example Bitmap_cubical_complex/Bitmap_cubical_complex_periodic_boundary_conditions.cpp
+ * @example Bottleneck_distance/bottleneck_distance.cpp
+ * @example Bitmap_cubical_complex/cubical_complex_persistence.cpp
+ * @example Bitmap_cubical_complex/periodic_cubical_complex_persistence.cpp
* @example Bitmap_cubical_complex/Random_bitmap_cubical_complex.cpp
* @example common/example_CGAL_3D_points_off_reader.cpp
* @example common/example_CGAL_points_off_reader.cpp