summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml13
1 files changed, 10 insertions, 3 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index e481c62f..82520c40 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -56,9 +56,16 @@ build_script:
ECHO %PYTHONPATH% &
cd src/cython &
python setup.py install &
- ECHO This fails : python -c "import gudhi; print(gudhi.__version__)" &
- ECHO This fails : MSBuild RUN_TESTS.vcxproj
) else (
MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64 &
- ctest -j 1 -C Release -E diff_files
)
+
+test_script:
+ - cd build
+ - if [%target%]==[Python] (
+ cd src/cython &
+ python -c "import gudhi; print(gudhi.__version__)" &
+ ECHO MSBuild RUN_TESTS.vcxproj
+ ) else (
+ ctest -j 1 -C Release -E diff_files
+ ) \ No newline at end of file