summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt254
-rw-r--r--src/CMakeLists.txt227
-rw-r--r--src/cmake/modules/GUDHI_third_party_libraries.txt86
3 files changed, 248 insertions, 319 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36e8afd7..18cd0ca2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,176 +5,88 @@ include(CMakeGUDHIVersion.txt)
# Generate GUDHI official version file
configure_file(GUDHIVersion.cmake.in "${CMAKE_SOURCE_DIR}/GUDHIVersion.cmake" @ONLY)
-find_package(Boost REQUIRED COMPONENTS system filesystem unit_test_framework chrono timer date_time program_options thread REQUIRED)
-
-if(NOT Boost_FOUND)
- message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
+set(CMAKE_PREFIX_PATH "${CMAKE_SOURCE_DIR}/src/cmake/modules/")
+set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/src/cmake/modules/")
+message("CMAKE_PREFIX_PATH = ${CMAKE_PREFIX_PATH}")
+message("CMAKE_MODULE_PATH = ${CMAKE_MODULE_PATH}")
+
+enable_testing()
+
+# For "make user_version"
+include("${CMAKE_MODULE_PATH}/GUDHI_user_version_target.txt")
+# For "make doxygen"
+include("${CMAKE_MODULE_PATH}/GUDHI_doxygen_target.txt")
+# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
+include("${CMAKE_MODULE_PATH}/GUDHI_third_party_libraries.txt")
+
+if(MSVC)
+ # Turn off some VC++ warnings
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
+endif()
- set(CMAKE_PREFIX_PATH "${CMAKE_SOURCE_DIR}/src/cmake/modules/")
- set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/src/cmake/modules/")
- message("CMAKE_PREFIX_PATH = ${CMAKE_PREFIX_PATH}")
- message("CMAKE_MODULE_PATH = ${CMAKE_MODULE_PATH}")
-
- enable_testing()
-
- # For "make user_version"
- include(${CMAKE_MODULE_PATH}/GUDHI_user_version_target.txt)
- # For "make doxygen"
- include(${CMAKE_MODULE_PATH}/GUDHI_doxygen_target.txt)
-
- find_package(GMP)
- if(GMP_FOUND)
- message(STATUS "GMP_LIBRARIES = ${GMP_LIBRARIES}")
- INCLUDE_DIRECTORIES(${GMP_INCLUDE_DIR})
- find_package(GMPXX)
- if(GMPXX_FOUND)
- message(STATUS "GMPXX_LIBRARIES = ${GMPXX_LIBRARIES}")
- INCLUDE_DIRECTORIES(${GMPXX_INCLUDE_DIR})
- endif()
- endif()
-
- # In CMakeLists.txt, when include(${CGAL_USE_FILE}), CMAKE_CXX_FLAGS are overwritten.
- # cf. http://doc.cgal.org/latest/Manual/installation.html#title40
- # A workaround is to include(${CGAL_USE_FILE}) before adding "-std=c++11".
- # A fix would be to use https://cmake.org/cmake/help/v3.1/prop_gbl/CMAKE_CXX_KNOWN_FEATURES.html
- # or even better https://cmake.org/cmake/help/v3.1/variable/CMAKE_CXX_STANDARD.html
- # but it implies to use cmake version 3.1 at least.
- find_package(CGAL)
- # Only CGAL versions > 4.4 supports what Gudhi uses from CGAL
- if (CGAL_VERSION VERSION_LESS 4.4.0)
- message("CGAL version ${CGAL_VERSION} is considered too old to be used by Gudhi.")
- unset(CGAL_FOUND)
- endif()
- if(CGAL_FOUND)
- message(STATUS "CGAL version: ${CGAL_VERSION}.")
- include( ${CGAL_USE_FILE} )
-
- if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
- include_directories(BEFORE "src/common/include/gudhi_patches")
- endif()
- endif()
-
- if(MSVC)
- # Turn off some VC++ warnings
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
- else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
- endif()
-
- if(CMAKE_BUILD_TYPE MATCHES Debug)
- message("++ Debug compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG}")
- else()
- message("++ Release compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE}")
- endif()
-
- set(Boost_USE_STATIC_LIBS ON)
- set(Boost_USE_MULTITHREADED ON)
- set(Boost_USE_STATIC_RUNTIME OFF)
-
- # Find TBB package for parallel sort - not mandatory, just optional.
- set(TBB_FIND_QUIETLY ON)
- find_package(TBB)
- if (TBB_FOUND)
- include(${TBB_USE_FILE})
- message("TBB found in ${TBB_LIBRARY_DIRS}")
- add_definitions(-DGUDHI_USE_TBB)
- endif()
-
- find_package(Eigen3 3.1.0)
- if (EIGEN3_FOUND)
- message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
- include( ${EIGEN3_USE_FILE} )
- #include_directories (BEFORE "../../include")
- endif (EIGEN3_FOUND)
-
- # Required programs for unitary tests purpose
- FIND_PROGRAM( GCOVR_PATH gcovr )
- if (GCOVR_PATH)
- message("gcovr found in ${GCOVR_PATH}")
- endif()
- # Required programs for unitary tests purpose
- FIND_PROGRAM( GPROF_PATH gprof )
- if (GPROF_PATH)
- message("gprof found in ${GPROF_PATH}")
- endif()
- FIND_PROGRAM( DIFF_PATH diff )
- if (DIFF_PATH)
- message("diff found in ${DIFF_PATH}")
- endif()
-
- # BOOST ISSUE result_of vs C++11
- add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
- # BOOST ISSUE with Libraries name resolution under Windows
- add_definitions(-DBOOST_ALL_NO_LIB)
- # problem with Visual Studio link on Boost program_options
- add_definitions( -DBOOST_ALL_DYN_LINK )
-
- INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
- LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
-
- message(STATUS "boost include dirs:" ${Boost_INCLUDE_DIRS})
- message(STATUS "boost library dirs:" ${Boost_LIBRARY_DIRS})
-
- if (DEBUG_TRACES)
- # For programs to be more verbose
- message(STATUS "DEBUG_TRACES are activated")
- add_definitions(-DDEBUG_TRACES)
- endif()
-
- include_directories(src/common/include/)
- include_directories(src/Alpha_complex/include/)
- include_directories(src/Bitmap_cubical_complex/include/)
- include_directories(src/Bottleneck_distance/include/)
- include_directories(src/Contraction/include/)
- include_directories(src/Hasse_complex/include/)
- include_directories(src/Persistent_cohomology/include/)
- include_directories(src/Rips_complex/include/)
- include_directories(src/Simplex_tree/include/)
- include_directories(src/Skeleton_blocker/include/)
- include_directories(src/Spatial_searching/include/)
- include_directories(src/Subsampling/include/)
- include_directories(src/Tangential_complex/include/)
- include_directories(src/Witness_complex/include/)
-
- add_subdirectory(src/common/example)
- add_subdirectory(src/common/test)
- add_subdirectory(src/Simplex_tree/test)
- add_subdirectory(src/Simplex_tree/example)
- add_subdirectory(src/Persistent_cohomology/test)
- add_subdirectory(src/Persistent_cohomology/example)
- add_subdirectory(src/Persistent_cohomology/benchmark)
- add_subdirectory(src/Skeleton_blocker/test)
- add_subdirectory(src/Skeleton_blocker/example)
- add_subdirectory(src/Contraction/example)
- add_subdirectory(src/Witness_complex/test)
- add_subdirectory(src/Witness_complex/example)
- add_subdirectory(src/Bitmap_cubical_complex/test)
- add_subdirectory(src/Bitmap_cubical_complex/example)
- add_subdirectory(src/Alpha_complex/example)
- add_subdirectory(src/Alpha_complex/test)
- add_subdirectory(src/Spatial_searching/example)
- add_subdirectory(src/Spatial_searching/test)
- add_subdirectory(src/Subsampling/example)
- add_subdirectory(src/Subsampling/test)
- add_subdirectory(src/Tangential_complex/example)
- add_subdirectory(src/Tangential_complex/test)
- add_subdirectory(src/Tangential_complex/benchmark)
- add_subdirectory(src/Bottleneck_distance/example)
- add_subdirectory(src/Bottleneck_distance/test)
- add_subdirectory(src/Bottleneck_distance/benchmark)
- add_subdirectory(src/Rips_complex/example)
- add_subdirectory(src/Rips_complex/test)
-
- # data points generator
- add_subdirectory(data/points/generator)
-
- add_subdirectory(src/GudhUI)
-
- # This variable is used by Cython CMakeLists.txt to know its path
- set(GUDHI_CYTHON_PATH "src/cython")
- add_subdirectory(${GUDHI_CYTHON_PATH})
-
-endif()
-
-
+if(CMAKE_BUILD_TYPE MATCHES Debug)
+ message("++ Debug compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG}")
+else()
+ message("++ Release compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE}")
+endif()
+
+if (DEBUG_TRACES)
+ # For programs to be more verbose
+ message(STATUS "DEBUG_TRACES are activated")
+ add_definitions(-DDEBUG_TRACES)
+endif()
+
+include_directories(src/common/include/)
+include_directories(src/Alpha_complex/include/)
+include_directories(src/Bitmap_cubical_complex/include/)
+include_directories(src/Bottleneck_distance/include/)
+include_directories(src/Contraction/include/)
+include_directories(src/Hasse_complex/include/)
+include_directories(src/Persistent_cohomology/include/)
+include_directories(src/Rips_complex/include/)
+include_directories(src/Simplex_tree/include/)
+include_directories(src/Skeleton_blocker/include/)
+include_directories(src/Spatial_searching/include/)
+include_directories(src/Subsampling/include/)
+include_directories(src/Tangential_complex/include/)
+include_directories(src/Witness_complex/include/)
+
+add_subdirectory(src/common/example)
+add_subdirectory(src/common/test)
+add_subdirectory(src/Simplex_tree/test)
+add_subdirectory(src/Simplex_tree/example)
+add_subdirectory(src/Persistent_cohomology/test)
+add_subdirectory(src/Persistent_cohomology/example)
+add_subdirectory(src/Persistent_cohomology/benchmark)
+add_subdirectory(src/Skeleton_blocker/test)
+add_subdirectory(src/Skeleton_blocker/example)
+add_subdirectory(src/Contraction/example)
+add_subdirectory(src/Witness_complex/test)
+add_subdirectory(src/Witness_complex/example)
+add_subdirectory(src/Bitmap_cubical_complex/test)
+add_subdirectory(src/Bitmap_cubical_complex/example)
+add_subdirectory(src/Alpha_complex/example)
+add_subdirectory(src/Alpha_complex/test)
+add_subdirectory(src/Spatial_searching/example)
+add_subdirectory(src/Spatial_searching/test)
+add_subdirectory(src/Subsampling/example)
+add_subdirectory(src/Subsampling/test)
+add_subdirectory(src/Tangential_complex/example)
+add_subdirectory(src/Tangential_complex/test)
+add_subdirectory(src/Tangential_complex/benchmark)
+add_subdirectory(src/Bottleneck_distance/example)
+add_subdirectory(src/Bottleneck_distance/test)
+add_subdirectory(src/Bottleneck_distance/benchmark)
+add_subdirectory(src/Rips_complex/example)
+add_subdirectory(src/Rips_complex/test)
+
+# data points generator
+add_subdirectory(data/points/generator)
+
+add_subdirectory(src/GudhUI)
+
+# This variable is used by Cython CMakeLists.txt to know its path
+set(GUDHI_CYTHON_PATH "src/cython")
+add_subdirectory(${GUDHI_CYTHON_PATH})
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index abd4d12c..4fa73662 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,154 +9,85 @@ enable_testing()
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules/")
-find_package(Boost REQUIRED COMPONENTS system filesystem program_options chrono timer date_time REQUIRED)
+# For "make doxygen"
+set(GUDHI_USER_VERSION_DIR ${CMAKE_SOURCE_DIR})
+include(${CMAKE_MODULE_PATH}/GUDHI_doxygen_target.txt)
-if(NOT Boost_FOUND)
- message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
+# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
+include("${CMAKE_MODULE_PATH}/GUDHI_third_party_libraries.txt")
+
+if(MSVC)
+ # Turn off some VC++ warnings
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
+endif()
- # For "make doxygen"
- set(GUDHI_USER_VERSION_DIR ${CMAKE_SOURCE_DIR})
- include(${CMAKE_MODULE_PATH}/GUDHI_doxygen_target.txt)
-
- find_package(GMP)
- if(GMP_FOUND)
- message(STATUS "GMP_LIBRARIES = ${GMP_LIBRARIES}")
- INCLUDE_DIRECTORIES(${GMP_INCLUDE_DIR})
- find_package(GMPXX)
- if(GMPXX_FOUND)
- message(STATUS "GMPXX_LIBRARIES = ${GMPXX_LIBRARIES}")
- INCLUDE_DIRECTORIES(${GMPXX_INCLUDE_DIR})
- endif()
- endif()
-
- # In CMakeLists.txt, when include(${CGAL_USE_FILE}), CMAKE_CXX_FLAGS are overwritten.
- # cf. http://doc.cgal.org/latest/Manual/installation.html#title40
- # A workaround is to include(${CGAL_USE_FILE}) before adding "-std=c++11".
- # A fix would be to use https://cmake.org/cmake/help/v3.1/prop_gbl/CMAKE_CXX_KNOWN_FEATURES.html
- # or even better https://cmake.org/cmake/help/v3.1/variable/CMAKE_CXX_STANDARD.html
- # but it implies to use cmake version 3.1 at least.
-
- # find CGAL in QUIET mode for cmake to be less verbose when CGAL is not found.
- find_package(CGAL QUIET)
- # Only CGAL versions > 4.4 supports what Gudhi uses from CGAL
- if (CGAL_VERSION VERSION_LESS 4.4.0 AND CGAL_FOUND)
- message("CGAL version ${CGAL_VERSION} is considered too old to be used by Gudhi.")
- unset(CGAL_FOUND)
- endif(CGAL_VERSION VERSION_LESS 4.4.0 AND CGAL_FOUND)
- if(CGAL_FOUND)
- message(STATUS "CGAL version: ${CGAL_VERSION}.")
- include( ${CGAL_USE_FILE} )
-
- if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
- include_directories(BEFORE "include/gudhi_patches")
- endif()
- endif()
-
- if(MSVC)
- # Turn off some VC++ warnings
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
- else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
- endif()
-
- if(CMAKE_BUILD_TYPE MATCHES Debug)
- message("++ Debug compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG}")
- else()
- message("++ Release compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE}")
- endif()
-
- set(Boost_USE_STATIC_LIBS ON)
- set(Boost_USE_MULTITHREADED ON)
- set(Boost_USE_STATIC_RUNTIME OFF)
-
- # Find TBB package for parallel sort - not mandatory, just optional.
- set(TBB_FIND_QUIETLY ON)
- find_package(TBB)
- if (TBB_FOUND)
- include(${TBB_USE_FILE})
- message("TBB found in ${TBB_LIBRARY_DIRS}")
- add_definitions(-DGUDHI_USE_TBB)
- endif()
-
- find_package(Eigen3 3.1.0)
- if (EIGEN3_FOUND)
- message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
- include( ${EIGEN3_USE_FILE} )
- #include_directories (BEFORE "../../include")
- endif (EIGEN3_FOUND)
-
- # BOOST ISSUE result_of vs C++11
- add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
- # BOOST ISSUE with Libraries name resolution under Windows
- add_definitions(-DBOOST_ALL_NO_LIB)
- # problem with Visual Studio link on Boost program_options
- add_definitions( -DBOOST_ALL_DYN_LINK )
-
- INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
- LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
-
- if (DEBUG_TRACES)
- message(STATUS "DEBUG_TRACES are activated")
- # For programs to be more verbose
- add_definitions(-DDEBUG_TRACES)
- endif()
-
- #---------------------------------------------------------------------------------------
- # Gudhi compilation part
- include_directories(include)
-
- add_subdirectory(example/common)
- add_subdirectory(example/Simplex_tree)
- add_subdirectory(example/Persistent_cohomology)
- add_subdirectory(example/Skeleton_blocker)
- add_subdirectory(example/Contraction)
- add_subdirectory(example/Bitmap_cubical_complex)
- add_subdirectory(example/Witness_complex)
- add_subdirectory(example/Alpha_complex)
- add_subdirectory(example/Rips_complex)
- add_subdirectory(example/Spatial_searching)
- add_subdirectory(example/Subsampling)
- add_subdirectory(example/Tangential_complex)
- add_subdirectory(example/Bottleneck_distance)
-
- # data points generator
- add_subdirectory(data/points/generator)
-
- # Please let GudhUI in last compilation position as QT is known to modify CMAKE_CXX_FLAGS
- # GudhUI
- add_subdirectory(GudhUI)
-
- # This variable is used by Cython CMakeLists.txt to know its path
- set(GUDHI_CYTHON_PATH "cython")
- add_subdirectory(${GUDHI_CYTHON_PATH})
- #---------------------------------------------------------------------------------------
-
- #---------------------------------------------------------------------------------------
- # GUDHIConfig.cmake
- # Export the package for use from the build-tree
- # (this registers the build-tree with a global CMake-registry)
- export(PACKAGE GUDHI)
-
- message("++ make install will install ${PROJECT_NAME} in the following directory : ${CMAKE_INSTALL_PREFIX}")
- # Create the GUDHIConfig.cmake and GUDHIConfigVersion files
- set(CONF_INCLUDE_DIRS "${CMAKE_INSTALL_PREFIX}/include")
- configure_file(GUDHIConfig.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake" @ONLY)
- configure_file(GUDHIConfigVersion.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake" @ONLY)
-
- #---------------------------------------------------------------------------------------
-
- #---------------------------------------------------------------------------------------
- # Gudhi installation part
-
- # Install the GUDHIConfig.cmake and GUDHIConfigVersion.cmake
- install(FILES
- "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake"
- "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake"
- DESTINATION share/gudhi)
-
- # install the include file on "make install"
- install(DIRECTORY include/gudhi DESTINATION include)
- #---------------------------------------------------------------------------------------
-
-endif()
+if(CMAKE_BUILD_TYPE MATCHES Debug)
+ message("++ Debug compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG}")
+else()
+ message("++ Release compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE}")
+endif()
+
+if (DEBUG_TRACES)
+ message(STATUS "DEBUG_TRACES are activated")
+ # For programs to be more verbose
+ add_definitions(-DDEBUG_TRACES)
+endif()
+
+#---------------------------------------------------------------------------------------
+# Gudhi compilation part
+include_directories(include)
+
+add_subdirectory(example/common)
+add_subdirectory(example/Simplex_tree)
+add_subdirectory(example/Persistent_cohomology)
+add_subdirectory(example/Skeleton_blocker)
+add_subdirectory(example/Contraction)
+add_subdirectory(example/Bitmap_cubical_complex)
+add_subdirectory(example/Witness_complex)
+add_subdirectory(example/Alpha_complex)
+add_subdirectory(example/Rips_complex)
+add_subdirectory(example/Spatial_searching)
+add_subdirectory(example/Subsampling)
+add_subdirectory(example/Tangential_complex)
+add_subdirectory(example/Bottleneck_distance)
+
+# data points generator
+add_subdirectory(data/points/generator)
+
+# Please let GudhUI in last compilation position as QT is known to modify CMAKE_CXX_FLAGS
+# GudhUI
+add_subdirectory(GudhUI)
+
+# This variable is used by Cython CMakeLists.txt to know its path
+set(GUDHI_CYTHON_PATH "cython")
+add_subdirectory(${GUDHI_CYTHON_PATH})
+#---------------------------------------------------------------------------------------
+
+#---------------------------------------------------------------------------------------
+# GUDHIConfig.cmake
+# Export the package for use from the build-tree
+# (this registers the build-tree with a global CMake-registry)
+export(PACKAGE GUDHI)
+
+message("++ make install will install ${PROJECT_NAME} in the following directory : ${CMAKE_INSTALL_PREFIX}")
+# Create the GUDHIConfig.cmake and GUDHIConfigVersion files
+set(CONF_INCLUDE_DIRS "${CMAKE_INSTALL_PREFIX}/include")
+configure_file(GUDHIConfig.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake" @ONLY)
+configure_file(GUDHIConfigVersion.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake" @ONLY)
+
+#---------------------------------------------------------------------------------------
+
+#---------------------------------------------------------------------------------------
+# Gudhi installation part
+
+# Install the GUDHIConfig.cmake and GUDHIConfigVersion.cmake
+install(FILES
+ "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake"
+ "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake"
+ DESTINATION share/gudhi)
+
+# install the include file on "make install"
+install(DIRECTORY include/gudhi DESTINATION include)
+#---------------------------------------------------------------------------------------
diff --git a/src/cmake/modules/GUDHI_third_party_libraries.txt b/src/cmake/modules/GUDHI_third_party_libraries.txt
new file mode 100644
index 00000000..1a2b510f
--- /dev/null
+++ b/src/cmake/modules/GUDHI_third_party_libraries.txt
@@ -0,0 +1,86 @@
+# This files manage third party libraries required by GUDHI
+
+find_package(Boost REQUIRED COMPONENTS system filesystem unit_test_framework chrono timer date_time program_options thread REQUIRED)
+
+if(NOT Boost_FOUND)
+ message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
+endif(NOT Boost_FOUND)
+
+find_package(GMP)
+if(GMP_FOUND)
+ message(STATUS "GMP_LIBRARIES = ${GMP_LIBRARIES}")
+ INCLUDE_DIRECTORIES(${GMP_INCLUDE_DIR})
+ find_package(GMPXX)
+ if(GMPXX_FOUND)
+ message(STATUS "GMPXX_LIBRARIES = ${GMPXX_LIBRARIES}")
+ INCLUDE_DIRECTORIES(${GMPXX_INCLUDE_DIR})
+ endif()
+endif()
+
+# In CMakeLists.txt, when include(${CGAL_USE_FILE}), CMAKE_CXX_FLAGS are overwritten.
+# cf. http://doc.cgal.org/latest/Manual/installation.html#title40
+# A workaround is to include(${CGAL_USE_FILE}) before adding "-std=c++11".
+# A fix would be to use https://cmake.org/cmake/help/v3.1/prop_gbl/CMAKE_CXX_KNOWN_FEATURES.html
+# or even better https://cmake.org/cmake/help/v3.1/variable/CMAKE_CXX_STANDARD.html
+# but it implies to use cmake version 3.1 at least.
+find_package(CGAL)
+# Only CGAL versions > 4.4 supports what Gudhi uses from CGAL
+if (CGAL_VERSION VERSION_LESS 4.4.0)
+ message("CGAL version ${CGAL_VERSION} is considered too old to be used by Gudhi.")
+ unset(CGAL_FOUND)
+endif()
+if(CGAL_FOUND)
+ message(STATUS "CGAL version: ${CGAL_VERSION}.")
+ include( ${CGAL_USE_FILE} )
+
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ # For dev version
+ include_directories(BEFORE "src/common/include/gudhi_patches")
+ # For user version
+ include_directories(BEFORE "include/gudhi_patches")
+ endif()
+endif()
+
+# Find TBB package for parallel sort - not mandatory, just optional.
+set(TBB_FIND_QUIETLY ON)
+find_package(TBB)
+if (TBB_FOUND)
+ include(${TBB_USE_FILE})
+ message("TBB found in ${TBB_LIBRARY_DIRS}")
+ add_definitions(-DGUDHI_USE_TBB)
+endif()
+
+find_package(Eigen3 3.1.0)
+if (EIGEN3_FOUND)
+ message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
+ include( ${EIGEN3_USE_FILE} )
+ #include_directories (BEFORE "../../include")
+endif (EIGEN3_FOUND)
+
+# Required programs for unitary tests purpose
+FIND_PROGRAM( GCOVR_PATH gcovr )
+if (GCOVR_PATH)
+ message("gcovr found in ${GCOVR_PATH}")
+endif()
+# Required programs for unitary tests purpose
+FIND_PROGRAM( GPROF_PATH gprof )
+if (GPROF_PATH)
+ message("gprof found in ${GPROF_PATH}")
+endif()
+FIND_PROGRAM( DIFF_PATH diff )
+if (DIFF_PATH)
+ message("diff found in ${DIFF_PATH}")
+endif()
+
+# BOOST ISSUE result_of vs C++11
+add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
+# BOOST ISSUE with Libraries name resolution under Windows
+add_definitions(-DBOOST_ALL_NO_LIB)
+# problem with Visual Studio link on Boost program_options
+add_definitions( -DBOOST_ALL_DYN_LINK )
+
+INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+
+message(STATUS "boost include dirs:" ${Boost_INCLUDE_DIRS})
+message(STATUS "boost library dirs:" ${Boost_LIBRARY_DIRS})