summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml29
-rw-r--r--src/Alpha_complex/test/Alpha_complex_unit_test.cpp2
-rw-r--r--src/Doxyfile.in2
-rw-r--r--src/common/doc/MathJax.js53
4 files changed, 14 insertions, 72 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index dea0fc15..31eb48d4 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -13,17 +13,17 @@ environment:
APPVEYOR_SAVE_CACHE_ON_ERROR: true
matrix:
-# - target: Examples
-# CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=ON -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF
-# PYTHON: "C:\\Python37-x64"
-#
-# - target: UnitaryTests
-# CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF
-# PYTHON: "C:\\Python37-x64"
-#
-# - target: Utilities
-# CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=OFF
-# PYTHON: "C:\\Python37-x64"
+ - target: Examples
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=ON -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF
+ PYTHON: "C:\\Python37-x64"
+
+ - target: UnitaryTests
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF
+ PYTHON: "C:\\Python37-x64"
+
+ - target: Utilities
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=OFF
+ PYTHON: "C:\\Python37-x64"
- target: Python
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DGMP_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpir.lib" -DGMP_LIBRARIES_DIR="c:/Tools/vcpkg/installed/x64-windows/lib"
@@ -40,10 +40,9 @@ init:
install:
- vcpkg install tbb:x64-windows boost-disjoint-sets:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows mpfr:x64-windows mpir:x64-windows cgal:x64-windows
+ - SET PATH=c:\Tools\vcpkg\installed\x64-windows\bin;%PATH%
- SET PATH=%PYTHON%;%PYTHON%\Scripts;%PYTHON%\Library\bin;%PATH%
- - "ECHO %PYTHON%"
- SET PYTHONPATH=%PYTHON%\\Lib\\site-packages;%PYTHONPATH%
- - "ECHO %PYTHONPATH%"
- CALL "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat" amd64
- python --version
- pip --version
@@ -55,12 +54,8 @@ build_script:
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- if [%target%]==[Python] (
- ECHO %PYTHONPATH% &
cd src/cython &
- Type setup.py &
python setup.py install &
- DIR %PYTHON%\\Lib\\site-packages &
- python -c "import gudhi; print(gudhi.__version__)" &
MSBuild RUN_TESTS.vcxproj
) else (
MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64 &
diff --git a/src/Alpha_complex/test/Alpha_complex_unit_test.cpp b/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
index 622fcae8..b46b6da5 100644
--- a/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
+++ b/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
@@ -42,7 +42,7 @@
// Use dynamic_dimension_tag for the user to be able to set dimension
typedef CGAL::Epick_d< CGAL::Dynamic_dimension_tag > Kernel_d;
// Use static dimension_tag for the user not to be able to set dimension
-typedef CGAL::Epick_d< CGAL::Dimension_tag<2> > Kernel_s;
+typedef CGAL::Epick_d< CGAL::Dimension_tag<3> > Kernel_s;
// The triangulation uses the default instantiation of the TriangulationDataStructure template parameter
typedef boost::mpl::list<Kernel_d, Kernel_s> list_of_kernel_variants;
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
index 5b1b8ecc..f80d4505 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
@@ -1441,7 +1441,7 @@ MATHJAX_FORMAT = HTML-CSS
# The default value is: http://cdn.mathjax.org/mathjax/latest.
# This tag requires that the tag USE_MATHJAX is set to YES.
-MATHJAX_RELPATH = ../common
+MATHJAX_RELPATH = https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.2
# The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
# extension names that should be enabled during MathJax rendering. For example
diff --git a/src/common/doc/MathJax.js b/src/common/doc/MathJax.js
deleted file mode 100644
index 35e1994e..00000000
--- a/src/common/doc/MathJax.js
+++ /dev/null
@@ -1,53 +0,0 @@
-(function () {
- var newMathJax = 'https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js';
- var oldMathJax = 'cdn.mathjax.org/mathjax/latest/MathJax.js';
-
- var replaceScript = function (script, src) {
- //
- // Make redirected script
- //
- var newScript = document.createElement('script');
- newScript.src = newMathJax + src.replace(/.*?(\?|$)/, '$1');
- //
- // Move onload and onerror handlers to new script
- //
- newScript.onload = script.onload;
- newScript.onerror = script.onerror;
- script.onload = script.onerror = null;
- //
- // Move any content (old-style configuration scripts)
- //
- while (script.firstChild) newScript.appendChild(script.firstChild);
- //
- // Copy script id
- //
- if (script.id != null) newScript.id = script.id;
- //
- // Replace original script with new one
- //
- script.parentNode.replaceChild(newScript, script);
- //
- // Issue a console warning
- //
- console.warn('WARNING: cdn.mathjax.org has been retired. Check https://www.mathjax.org/cdn-shutting-down/ for migration tips.')
- }
-
- if (document.currentScript) {
- var script = document.currentScript;
- replaceScript(script, script.src);
- } else {
- //
- // Look for current script by searching for one with the right source
- //
- var n = oldMathJax.length;
- var scripts = document.getElementsByTagName('script');
- for (var i = 0; i < scripts.length; i++) {
- var script = scripts[i];
- var src = (script.src || '').replace(/.*?:\/\//,'');
- if (src.substr(0, n) === oldMathJax) {
- replaceScript(script, src);
- break;
- }
- }
- }
-})(); \ No newline at end of file