summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index dba306ef..3a28c2ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,9 +23,9 @@ endif
%:
# The --buildirectory=build is there so that we can easily get a hold
# of documentation and examples, which are not installed by upstream.
- dh $@ $(DHFLAGS) --builddirectory=build
+ dh $@ $(DHFLAGS) --with=python3 --builddirectory=build
for py3ver in $(REMAINING_PY3VERS) ; do \
- dh $@ $(DHFLAGS) --builddirectory=build$$py3ver ; \
+ dh $@ $(DHFLAGS) --with=python3 --builddirectory=build$$py3ver ; \
done
override_dh_auto_configure:
@@ -99,3 +99,6 @@ override_dh_auto_install:
override_dh_compress:
dh_compress -X.cpp
+
+override_dh_install:
+ dh_install -X__pycache__ -X.pyc -X.pyo