summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml7
1 files changed, 5 insertions, 2 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 95dc7a3e..fe9c7a8e 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -40,5 +40,8 @@ build_script:
- mkdir build
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- - MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
- - ctest -j 1 -C Release -E diff_files
+ - if NOT "%target%"=="Python" MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
+ - if NOT "%target%"=="Python" ctest -j 1 -C Release -E diff_files
+ - if "%target%"=="Python" cd src/cython
+ - if "%target%"=="Python" python setup.py install
+ - if "%target%"=="Python" MSBuild RUN_TESTS.vcxproj