summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules11
2 files changed, 17 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c6455801..5df41189 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gudhi (3.0.0+dfsg-3) UNRELEASED; urgency=medium
+
+ * Disable build-time tests on s390x. See #943384.
+
+ -- Gard Spreemann <gspr@nonempty.org> Thu, 24 Oct 2019 09:34:05 +0200
+
gudhi (3.0.0+dfsg-2) unstable; urgency=medium
* Fix binary-arch build.
diff --git a/debian/rules b/debian/rules
index a7a12f0e..889ba625 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,6 +20,11 @@ ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mi
DHFLAGS+=--no-parallel
endif
+# Disable tests on s390x, as a few are broken. See #943384.
+ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),s390x))
+ export DEB_BUILD_MAINT_OPTIONS := $(DEB_BUILD_MAINT_OPTIONS) nocheck
+endif
+
%:
# The --buildirectory=build is there so that we can easily get a hold
# of documentation and examples, which are not installed by upstream.
@@ -47,10 +52,16 @@ override_dh_auto_build-indep:
override_dh_auto_test-indep:
override_dh_auto_test-arch:
+# I believe this should be handled automatically by dh_auto_test,
+# but see #901678.
+ifeq (, $(findstring nocheck,$(DEB_BUILD_MAINT_OPTIONS)))
dh_auto_test $(DHFLAGS) --no-parallel --builddirectory=build
for py3ver in $(REMAINING_PY3VERS) ; do \
dh_auto_test $(DHFLAGS) --no-parallel --builddirectory=build$$py3ver ; \
done
+else
+ @echo "Skipping tests due to nocheck flag."
+endif
override_dh_auto_install:
find src -type f -path '*/example/*' \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'name=$$(echo $$0 | sed s/src\\/// | sed s/example\\///); install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$name' {} \;