summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt3
-rw-r--r--src/Doxyfile10
-rw-r--r--src/Witness_complex/example/example_nearest_landmark_table.cpp6
3 files changed, 10 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5185391b..36e8afd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,6 +93,7 @@ else()
if (GCOVR_PATH)
message("gcovr found in ${GCOVR_PATH}")
endif()
+ # Required programs for unitary tests purpose
FIND_PROGRAM( GPROF_PATH gprof )
if (GPROF_PATH)
message("gprof found in ${GPROF_PATH}")
@@ -168,8 +169,6 @@ else()
# data points generator
add_subdirectory(data/points/generator)
- # Please let GudhUI in last compilation position as QT is known to modify CMAKE_CXX_FLAGS
- # GudhUI
add_subdirectory(src/GudhUI)
# This variable is used by Cython CMakeLists.txt to know its path
diff --git a/src/Doxyfile b/src/Doxyfile
index 9f08024c..d2d0a447 100644
--- a/src/Doxyfile
+++ b/src/Doxyfile
@@ -500,7 +500,7 @@ HIDE_SCOPE_NAMES = NO
# the files that are included by a file in the documentation of that file.
# The default value is: YES.
-SHOW_INCLUDE_FILES = YES
+SHOW_INCLUDE_FILES = NO
# If the SHOW_GROUPED_MEMB_INC tag is set to YES then Doxygen will add for each
# grouped member an include statement to the documentation, telling the reader
@@ -847,9 +847,11 @@ IMAGE_PATH = doc/Skeleton_blocker/ \
doc/Persistent_cohomology/ \
doc/Witness_complex/ \
doc/Bitmap_cubical_complex/ \
+ doc/Rips_complex/ \
doc/Subsampling/ \
doc/Spatial_searching/ \
- doc/Tangential_complex/
+ doc/Tangential_complex/ \
+ doc/Bottleneck_distance/
# The INPUT_FILTER tag can be used to specify a program that doxygen should
# invoke to filter for each input file. Doxygen will invoke the filter program
@@ -2151,7 +2153,7 @@ TEMPLATE_RELATIONS = YES
# The default value is: YES.
# This tag requires that the tag HAVE_DOT is set to YES.
-INCLUDE_GRAPH = YES
+INCLUDE_GRAPH = NO
# If the INCLUDED_BY_GRAPH, ENABLE_PREPROCESSING and SEARCH_INCLUDES tags are
# set to YES then doxygen will generate a graph for each documented file showing
@@ -2160,7 +2162,7 @@ INCLUDE_GRAPH = YES
# The default value is: YES.
# This tag requires that the tag HAVE_DOT is set to YES.
-INCLUDED_BY_GRAPH = YES
+INCLUDED_BY_GRAPH = NO
# If the CALL_GRAPH tag is set to YES then doxygen will generate a call
# dependency graph for every global function or class method.
diff --git a/src/Witness_complex/example/example_nearest_landmark_table.cpp b/src/Witness_complex/example/example_nearest_landmark_table.cpp
index 7084d416..b8594212 100644
--- a/src/Witness_complex/example/example_nearest_landmark_table.cpp
+++ b/src/Witness_complex/example/example_nearest_landmark_table.cpp
@@ -23,7 +23,7 @@
#define BOOST_PARAMETER_MAX_ARITY 12
#include <gudhi/Simplex_tree.h>
-#include <gudhi/Strong_witness_complex.h>
+#include <gudhi/Witness_complex.h>
#include <gudhi/Persistent_cohomology.h>
#include <iostream>
@@ -35,7 +35,7 @@
int main(int argc, char * const argv[]) {
using Nearest_landmark_range = std::vector<std::pair<std::size_t, double>>;
using Nearest_landmark_table = std::vector<Nearest_landmark_range>;
- using Witness_complex = Gudhi::witness_complex::Strong_witness_complex<Nearest_landmark_table>;
+ using Witness_complex = Gudhi::witness_complex::Witness_complex<Nearest_landmark_table>;
using Simplex_tree = Gudhi::Simplex_tree<>;
using Field_Zp = Gudhi::persistent_cohomology::Field_Zp;
using Persistent_cohomology = Gudhi::persistent_cohomology::Persistent_cohomology<Simplex_tree, Field_Zp>;
@@ -56,7 +56,7 @@ int main(int argc, char * const argv[]) {
std::make_pair(2, 3), std::make_pair(3, 4)}; nlt.push_back(w4);
Witness_complex witness_complex(nlt);
- witness_complex.create_complex(simplex_tree, 4.1, 2);
+ witness_complex.create_complex(simplex_tree, 4.1);
std::cout << "Number of simplices: " << simplex_tree.num_simplices() << std::endl;