summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml15
1 files changed, 3 insertions, 12 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 49405619..c6475f2e 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -55,18 +55,9 @@ build_script:
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- if [%target%]==[Python] (
cd src/cython &
- python setup.py install
- ) else (
- MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
- )
-
-test_script:
- - cd build
- - if [%target%]==[Python] (
- DIR src/cython &
- cd src/cython &
- python -c "import gudhi; print(gudhi.__version__)" &
+ python setup.py install &
MSBuild RUN_TESTS.vcxproj
) else (
+ MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64 &
ctest -j 1 -C Release -E diff_files
- ) \ No newline at end of file
+ )