summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/control3
-rw-r--r--debian/python3-gudhi.install2
-rwxr-xr-xdebian/rules22
4 files changed, 29 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index ebf4b8aa..a075d8e5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gudhi (2.2.0+dfsg-2) UNRELEASED; urgency=medium
+
+ * Build Python bindings for all supported Python (3) versions.
+
+ -- Gard Spreemann <gspreemann@gmail.com> Tue, 07 Aug 2018 00:19:30 +0200
+
gudhi (2.2.0+dfsg-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 00f91e6a..2b59b9ef 100644
--- a/debian/control
+++ b/debian/control
@@ -19,8 +19,7 @@ Build-Depends: cmake (>= 3.1),
libgmp-dev,
libqglviewer-dev-qt5,
libtbb-dev,
- python3-all,
- python3-dev,
+ python3-all-dev,
python3-matplotlib,
python3-pytest,
python3-tk,
diff --git a/debian/python3-gudhi.install b/debian/python3-gudhi.install
index 22b018bc..be9e3f27 100644
--- a/debian/python3-gudhi.install
+++ b/debian/python3-gudhi.install
@@ -1 +1 @@
-build/cython/gudhi*.so usr/lib/python3/dist-packages/
+debian/tmp/usr/lib/python3/dist-packages/cython/gudhi.cpython*.so usr/lib/python3/dist-packages/ \ No newline at end of file
diff --git a/debian/rules b/debian/rules
index 3047cf7e..a8813459 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,24 +7,44 @@ LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
TMPBIN:=debian/tmp/usr/bin
+PY3VERS:=$(shell py3versions -vs)
+FIRST_PY3VER:=$(word 1, $(PY3VERS))
+REMAINING_PY3VERS:=$(filter-out $(FIRST_PY3VER), $(PY3VERS))
+
%:
# The --buildirectory=build is there so that we can easily get a hold
# of documentation and examples, which are not installed by upstream.
dh $@ --with=python3 --builddirectory=build
+ for py3ver in $(REMAINING_PY3VERS) ; do \
+ dh $@ --with=python3 --builddirectory=build$$py3ver ; \
+ done
override_dh_auto_configure:
- dh_auto_configure -- -DWITH_GUDHI_BENCHMARK=true -DWITH_GUDHI_EXAMPLE=true -DWITH_GUDHI_PYTHON=true -DWITH_GUDHI_TEST=true -DWITH_GUDHI_UTILITIES=true
+ dh_auto_configure -- -DWITH_GUDHI_BENCHMARK=true -DWITH_GUDHI_EXAMPLE=true -DWITH_GUDHI_PYTHON=true -DWITH_GUDHI_TEST=true -DWITH_GUDHI_UTILITIES=true -DPython_ADDITIONAL_VERSIONS=$(FIRST_PY3VER)
+ for py3ver in $(REMAINING_PY3VERS) ; do \
+ dh_auto_configure --builddirectory=build$$py3ver -- -DWITH_GUDHI_BENCHMARK=false -DWITH_GUDHI_EXAMPLE=false -DWITH_GUDHI_PYTHON=true -DWITH_GUDHI_TEST=true -DWITH_GUDHI_UTILITIES=false -DPython_ADDITIONAL_VERSIONS=$$py3ver ; \
+ done
override_dh_auto_build-indep:
make -C build doxygen
dh_auto_build --builddirectory=build
+ for py3ver in $(REMAINING_PY3VERS) ; do \
+ dh_auto_build --builddirectory=build$$py3ver ; \
+ done
override_dh_auto_test:
dh_auto_test --no-parallel --builddirectory=build
+ for py3ver in $(REMAINING_PY3VERS) ; do \
+ dh_auto_test --no-parallel --builddirectory=build$$py3ver ; \
+ done
override_dh_auto_install:
find example -type f \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$0' {} \;
+
dh_auto_install --builddirectory=build
+ for py3ver in $(REMAINING_PY3VERS) ; do \
+ dh_auto_install --builddirectory=build$$py3ver ; \
+ done
# Remove installed information about Miniball header.
rm debian/tmp/usr/include/gudhi/Miniball.COPYRIGHT