summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt12
-rw-r--r--src/Contraction/utilities/CMakeLists.txt1
-rw-r--r--src/Persistent_cohomology/utilities/CMakeLists.txt2
3 files changed, 8 insertions, 7 deletions
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
index b37555f9..6a602dbb 100644
--- a/src/Bottleneck_distance/example/CMakeLists.txt
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -2,14 +2,16 @@ cmake_minimum_required(VERSION 2.6)
project(Bottleneck_distance_examples)
if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
- add_executable (bottleneck_read_file_example bottleneck_read_file_example.cpp)
add_executable (bottleneck_basic_example bottleneck_basic_example.cpp)
+ add_executable (bottleneck_read_file_example bottleneck_read_file_example.cpp)
add_test(NAME Bottleneck_distance_example_basic COMMAND $<TARGET_FILE:bottleneck_basic_example>)
+ add_test(NAME Bottleneck_read_file_example
+ COMMAND $<TARGET_FILE:bottleneck_read_file_example>
+ "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
+
install(TARGETS bottleneck_read_file_example DESTINATION bin)
install(TARGETS bottleneck_basic_example DESTINATION bin)
- if (TBB_FOUND)
- target_link_libraries(alpha_rips_persistence_bottleneck_distance ${TBB_LIBRARIES})
- endif(TBB_FOUND)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+
+endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
diff --git a/src/Contraction/utilities/CMakeLists.txt b/src/Contraction/utilities/CMakeLists.txt
index a18783ef..36efd99a 100644
--- a/src/Contraction/utilities/CMakeLists.txt
+++ b/src/Contraction/utilities/CMakeLists.txt
@@ -2,5 +2,6 @@ cmake_minimum_required(VERSION 2.6)
project(Contraction_utilities)
add_executable(GarlandHeckbert Garland_heckbert.cpp)
+target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY})
install(TARGETS GarlandHeckbert DESTINATION bin)
diff --git a/src/Persistent_cohomology/utilities/CMakeLists.txt b/src/Persistent_cohomology/utilities/CMakeLists.txt
index 5b315801..9a506b3f 100644
--- a/src/Persistent_cohomology/utilities/CMakeLists.txt
+++ b/src/Persistent_cohomology/utilities/CMakeLists.txt
@@ -19,5 +19,3 @@ add_test(NAME Persistent_cohomology_example_from_rips_on_tore_3D COMMAND $<TARGE
install(TARGETS rips_distance_matrix_persistence DESTINATION bin)
install(TARGETS rips_persistence DESTINATION bin)
-
-endif(CGAL_FOUND)