summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules5
2 files changed, 6 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index 35b9da2b..987dddea 100644
--- a/debian/control
+++ b/debian/control
@@ -3,13 +3,14 @@ Maintainer: Gard Spreemann <gspreemann@gmail.com>
Section: math
Priority: optional
Standards-Version: 3.9.8.0
-Build-Depends: cmake (>= 2.6), cython3, debhelper (>= 10), dh-python, doxygen,
- graphviz, libboost-chrono-dev (>= 1.48), libboost-filesystem-dev (>= 1.48),
+Build-Depends: cmake (>= 2.6), cython3, debhelper (>= 10), dh-python,
+ libboost-chrono-dev (>= 1.48), libboost-filesystem-dev (>= 1.48),
libboost-program-options-dev (>= 1.48), libboost-system-dev (>= 1.48),
libboost-test-dev (>= 1.48), libboost-timer-dev (>= 1.48),
libcgal-dev (>= 4.8.1), libcgal-qt5-dev (>= 4.8.1), libeigen3-dev (>= 3.1.0),
libgmp-dev (>= 4.2), libqglviewer-dev-qt5, libtbb-dev, python3-dev,
- python3-matplotlib, python3-tk, qtbase5-dev, texlive-science
+ python3-matplotlib, python3-tk, qtbase5-dev
+Build-Depends-Indep: doxygen, graphviz, texlive-science
Homepage: http://gudhi.gforge.inria.fr/
Vcs-Browser: https://git.nonempty.org/debian-gudhi
Vcs-Git: http://git.nonempty.org/debian-gudhi -b debian/sid
diff --git a/debian/rules b/debian/rules
index 7e9ba1ec..18ef0551 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,9 +15,8 @@ override_dh_auto_clean:
rm -rf doc/html
dh_auto_clean
-override_dh_auto_build:
+override_dh_auto_build-indep:
make -C build doxygen
- dh_auto_build
override_dh_auto_test:
dh_auto_test --no-parallel --builddirectory=build
@@ -26,5 +25,5 @@ override_dh_auto_install:
find build/example -executable -type f -exec sh -c 'install -D $$0 debian/tmp/usr/bin/libgudhi-example-$$(basename $$0)' {} \;
find example -type f \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$0' {} \;
install -D build/GudhUI/GudhUI debian/tmp/usr/bin/gudhui
- dh_auto_install
+ dh_auto_install --with=python3 --builddirectory=build