summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt6
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt2
-rw-r--r--src/Bottleneck_distance/test/CMakeLists.txt3
3 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 066a49cf..dccd59d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,7 @@ else()
include_directories(src/common/include/)
include_directories(src/Alpha_shapes/include/)
- include_directories(src/Bipartite_graphs_matching/include/)
+ include_directories(src/Bottleneck_distance/include/)
include_directories(src/Bottleneck/include/)
include_directories(src/Contraction/include/)
include_directories(src/Hasse_complex/include/)
@@ -75,8 +75,8 @@ else()
add_subdirectory(src/Hasse_complex/example)
add_subdirectory(src/Alpha_shapes/example)
add_subdirectory(src/Alpha_shapes/test)
- add_subdirectory(src/Bipartite_graphs_matching/example)
- add_subdirectory(src/Bipartite_graphs_matching/test)
+ add_subdirectory(src/Bottleneck_distance/example)
+ add_subdirectory(src/Bottleneck_distance/test)
# data points generator
add_subdirectory(data/points/generator)
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
index 4e8766cc..cc1b9091 100644
--- a/src/Bottleneck_distance/example/CMakeLists.txt
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -24,7 +24,7 @@ if(CGAL_FOUND)
include( ${EIGEN3_USE_FILE} )
include_directories (BEFORE "../../include")
- add_executable (basic_example basic.cpp)
+ add_executable (bottleneck_example bottleneck_example.cpp)
#add_test(dtoffrw_tore3D ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw ${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off 3)
else()
diff --git a/src/Bottleneck_distance/test/CMakeLists.txt b/src/Bottleneck_distance/test/CMakeLists.txt
index ab0461cc..1338ed6b 100644
--- a/src/Bottleneck_distance/test/CMakeLists.txt
+++ b/src/Bottleneck_distance/test/CMakeLists.txt
@@ -44,7 +44,8 @@ endif()
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -ggdb -O0")
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
-add_executable ( BottleneckUT bottleneck_unit_test.cpp )
+add_executable ( bottleneckUT bottleneck_unit_test.cpp )
+add_executable ( bottleneck_chrono bottleneck_chrono.cpp )
target_link_libraries(BottleneckUT ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
# Unitary tests