summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/python/setup.py.in22
1 files changed, 7 insertions, 15 deletions
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 852da910..b9f4e3f0 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -46,23 +46,15 @@ for module in cython_modules:
ext_modules = cythonize(ext_modules)
-ext_modules.append(Extension(
- 'gudhi.hera',
- sources = [source_dir + 'hera.cc'],
- language = 'c++',
- include_dirs = include_dirs +
- ['@HERA_WASSERSTEIN_INCLUDE_DIR@',
- pybind11.get_include(False), pybind11.get_include(True)],
- extra_compile_args=extra_compile_args + [@GUDHI_PYBIND11_EXTRA_COMPILE_ARGS@],
- ))
-
-if "bottleneck" in pybind11_modules:
+for module in pybind11_modules:
+ my_include_dirs = include_dirs + [pybind11.get_include(False), pybind11.get_include(True)]
+ if module == 'hera':
+ my_include_dirs = ['@HERA_WASSERSTEIN_INCLUDE_DIR@'] + my_include_dirs
ext_modules.append(Extension(
- 'gudhi.bottleneck',
- sources = [source_dir + 'bottleneck.cc'],
+ 'gudhi.' + module,
+ sources = [source_dir + module + '.cc'],
language = 'c++',
- include_dirs = include_dirs +
- [pybind11.get_include(False), pybind11.get_include(True)],
+ include_dirs = my_include_dirs,
extra_compile_args=extra_compile_args + [@GUDHI_PYBIND11_EXTRA_COMPILE_ARGS@],
extra_link_args=extra_link_args,
libraries=libraries,