summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18cd0ca2..f95407b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,8 @@ enable_testing()
include("${CMAKE_MODULE_PATH}/GUDHI_user_version_target.txt")
# For "make doxygen"
include("${CMAKE_MODULE_PATH}/GUDHI_doxygen_target.txt")
+# This variable is used by Cython CMakeLists.txt to know its path
+set(GUDHI_CYTHON_PATH "src/cython")
# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
include("${CMAKE_MODULE_PATH}/GUDHI_third_party_libraries.txt")
@@ -87,6 +89,6 @@ add_subdirectory(data/points/generator)
add_subdirectory(src/GudhUI)
-# This variable is used by Cython CMakeLists.txt to know its path
-set(GUDHI_CYTHON_PATH "src/cython")
+# specific for cython module
add_subdirectory(${GUDHI_CYTHON_PATH})
+add_subdirectory(${GUDHI_CYTHON_PATH}/example)